Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi ,

I have an Focus 2005 ZX4, it has no warranty because i bought it wrecked
When i start the car,,the engine idles at 1000 rpm an then goes high to 2000 to 2500 and then goes very slowly down again till 1000 rpm.
Every time i start the car it does the same
There is no check engine light on
What can be the problem ?

Thanks

Daniel Hernandez
 

·
Registered
Joined
·
189 Posts
Hmmm... let's see...

Check on the TPS, it might be loose, or needs to be replaced.
Check your Throttle Body if it's dirty, and not closing right - may just need a little cleaning up

I'm betting it's the TPS, but check on those two and if it doesn't do the trick, I'm sure other guys here will pitch in on troubleshooting your car.

Good luck dude!

marc
 

·
Registered
Joined
·
583 Posts
mine does that but not as high as 2500K it only does it once in a while. i would think thats the engines way of waking up. it rev's high because of emmissions too anyway right?
 

·
Registered
Joined
·
1,067 Posts
well, the SVT's do that with the stock program, and the general consensus is that it is to warm up the catylic converter faster.. maybe your particular tune is similar

Or... you could have a slight vacuum leak, and eventually your IAC is able to compensate for it, but it has to re-figure that out each time you start the car.
 

·
Registered
Joined
·
696 Posts
I have an '06 ZX4 ST and it does that on almost all start ups unless it's already warm. I hear it's common, but it doesn't make it right. Look into the TPS and TB like stated, or see about flashing your ECU and setting the idle revs yourself.
 
1 - 6 of 6 Posts
Top