Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
i recently installed an aem short ram intake on my focus i reset the computer by unplugging the battery and now when my car is warm and im driving. when i slow down at a light or stop sign my rpm's start to drop and eventuallly the engine shuts itsself off. i thought it was the throttle cable so i tightened it but that wasn't the problem its still doing it. has anyone had this problem before and how do you fix it?
 

·
Registered
Joined
·
1,632 Posts
Did the gauges peg when you reset the ecu? I would check your battery too. My battery was showing 10.5 volts and it would shut off like that too. Take a multimeter and check you battery. You should be 12.5 volts. If not I would take it to autozone or checkers and have them test it and see if it will take a charge.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #4
it only does it when the car is warmed up cause when i start it cold it naturally revs the car up to warm it up but when it is warm thats the only time it will warm up ill just be sitting at a light and watch my rpm's go up and down and then my engine just suddenly shuts off. is there any special way to clean the MAF or just wipe it off?no i don't think they peged it just looked normal like any other day.
 

·
Registered
Joined
·
1,632 Posts
Well when you reset the ecu and you go to turn the key on your gauge neddles should go all the way to the right, if not then you didn't leave the battery unhooked long enough and your ecu did not reset.

To clean the MAF just go to a parts store like Checkers and buy a can of MAF cleaner. DO NOT buy electronics cleaner make sure it is MAF Cleaner. All you do is take off your MAF and spray the inside if it and let it airdry. It drys quick.
 
1 - 5 of 5 Posts
Top