Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
ok so my check engine light came on the car... took it to my step dad who has a thing you hook to your car that checks the code can't think of whats it called right now.. anyways came up as something wrong with the egr system.. well he found a bolt was loose on the system thought that was the problem but the light came back on... not sure what to do i have over 60000 miles on it any ideas or suggestions on what to do will be helpfull thanks oh by the way its a 2.0 ztech motor
 

·
Registered
Joined
·
5,392 Posts
mmwfocus03 said:
ok so my check engine light came on the car... took it to my step dad who has a thing you hook to your car that checks the code can't think of whats it called right now.. anyways came up as something wrong with the egr system.. well he found a bolt was loose on the system thought that was the problem but the light came back on... not sure what to do i have over 60000 miles on it any ideas or suggestions on what to do will be helpfull thanks oh by the way its a 2.0 ztech motor
My guess is that it's leaking exhaust gas. Since you think you fixed the problem, unplug the battery for about an hour to reset the ECU. If the light comes back on again, ya didn't fix it.
 

·
Registered
Joined
·
5,392 Posts
Also check the weld on the EGR pipe flange that bolts to the exhaust manifold. Those welds are known for being crappy. Mine broke, so I had to remove the pipe and reweld that sumbitch.
 
1 - 4 of 4 Posts
Top