Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The last month or so my charge light would come on from time to time but it would go out in a few seconds, I checked the battery and it was fine, this went on for a while until the last couple days the charge light has stayed on the car was still running fine. Now this morning the charge light was once again on, but was joined by the brake light, the abs light and the traction control light, as well the car started to stall I noticed the radio seemed staticky and would fade in and out, then the car did stall it restarted after a few tries ( the battery still had life) and I was able to drive it home a few blocks away. Before I go spend big money fixing this does anyone have any idea as to what may cause this...
Thanks for any help.
 

·
Registered
Joined
·
268 Posts
This sounds like a bad ground cable. Cable could be lose or may have some corrosion on the terminals. Also, your alternator maybe going bad or the electrical connections to the alternator maybe shot. I check those and report back here.
If you have a multimeter, then this is a good way to check whether the battery is getting charge or not.
BTW, I am glad to hear that your warning lights work because whenever my battery dies or goes bad I usually never get some sort of warning.
 

·
Registered
Joined
·
124 Posts
/\ Good Advice.

I had allmost the same symptions and a few nights ago the car left me stranded for the first time since owning the car.

Turned out it was my alternator on the way out. 112,00 on orig one. It was intermitently charging the system. The way you described the additional lights on the dash coming on was exactly what happened to me right before the car finally died out.
 

·
I need BOOOOST!!!!!!
Joined
·
6,125 Posts
alternator is the most likely problem. could also be bad power or ground wires. just wanted to second that.
 
1 - 4 of 4 Posts
Top