Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i just replaced my egr valve because it was throwing an p0401 code and after replacing it i noticed my car is idling very rough and wants to stall. and now i have a p0171 code as well. do you think i possibly have a vaccum leak after i changed the egr valve. i have a 2001 ford focus zx3 107000 miles. also i have another code coming on that says i have a catalyst fail bank 1 and was wondering if it was the o2 sensor or the cat? code is p0420
 

·
Registered
Joined
·
1,222 Posts
Did you clear the ECU by disconnecting the battery?
Make sure there are no leaks?
My code p0171 was caused by a collapsed pcv hose in the rear of the motor at the bend of the tubing.
Also,Welcome to FocusFanatics!
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Posted via FF Mobile

I think a vacuum leak is a distinct possibility. I'd start by checking the hoses effected by the EGR change first. Easiest way is running a propane torch, unlit of course, along the vacuum lines. If the idle suddenly smooth out, you've found your leak.

[Off topic]
Deuce, you clear up your issue? Is it still making that Briggs & Straton racket?
[/off topic]
 

·
Registered
Joined
·
288 Posts
The P0401 code on a 2001 Zetec will all but certainly be caused by the DPFE sensor, not the EGR valve itself. I'm betting that in replacing the EGR valve, you introduced a gasket leak in addition to still not having cleared the original P0401 code. As others have mentioned, the collapsed PCV hose is another pattern failure on the early Zetec.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
thank you. and also when i changed the egr valve the stationary nuts that are on the pipe that goes to the exhaust manifold one of them came loose so i just put a normal bolt and a nut on it. do you think this would be the wrong thing to do?
 
1 - 5 of 5 Posts
Top