Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
so im having a big problem with my 03 svtf. when im driving it will randomly bog really hard and almost like shut the car down but it doesnt shut down. my hids will like shut off and stuff and so will my radio and the wipers have even turned on at times but if i just put the clutch in it comes back to live almost. i dont even need to let the clutch out just push it in. i havent been able to pin point anything causing it while driving so i think its random at this point. i replaced the plugs and wires and it didnt fix the problem. its not throwing any codes either so i cant have my cousins diagnose it. he talked to a friend that is a ford mechanic and he said it sounded like the ecu but he isnt real farmiliar with svts so he would talk to the guy who was and he also took the vin and run it through theyre system and see if its ever been in for problem like this or if its a common problem or anything like that. do these symptoms sound like my ecu is jacked to you guys?? how much does one of these cost? can they be re programmed or fixed or do you just have to buy a new one? thanks all
 

·
Premium Member
Joined
·
21,250 Posts
You'd have to get a new ECU, but if you want to try reprogramming, you can just reset it yourself by removing the neg terminal for 10 mins. Then after you connect the battery again, and now allow your engine to idle for 5 minutes without touching the accel. This will reset the air/fuel ratio.

I personally think it's the alternator, or the voltage regulator plug in the back of the alternator.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
these have been checked. it will work perfectly fine at times and then other times my radio will turn off when it happens and my wippers will turn on and crazy stuff like that. the car starts fine and can still pound my 1500 watt system in there with ease and the car will drive while pounding it it will also just idle to.
 
1 - 3 of 3 Posts
Top