Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My radiator fans would not come on at all and my car had overheated several times. I finally just pulled the fan assembly out to get a better look, and was able to solve my overheating probs. Can you spot the problem? This is exactly how it came out.

Front

rear
 

·
Registered
Joined
·
209 Posts
wait were they not connected to anything? it looks like the fans are just plugged into each other and not anything else. am i right?
 

·
w/ my magic bag
Joined
·
29,468 Posts
Look's like the connecter's to the fan's aren't connected or plugged in all the way.
 

·
Registered
Joined
·
418 Posts
How are those fans supposed to cool your car when they're not even mounted?

*There's* your problem...duh...
 

·
Registered
Joined
·
2,484 Posts
Thats stupid who did that?

The white plug looks like it goes to some sensor down at the bottom between the 2 fans, then the other plug is suppose to power the fans.
 

·
w/ my magic bag
Joined
·
29,468 Posts
Well, you going to tell us?

My radiator fans would not come on at all and my car had overheated several times. I finally just pulled the fan assembly out to get a better look, and was able to solve my overheating probs. Can you spot the problem? This is exactly how it came out.

Front

rear
You going to tell us what you found, or what? Come on, we want to know!
 

·
Registered
Joined
·
2,484 Posts
That has to be it i looked at mine and i can see the 2 leads his has.
 

·
BodyKits=PantiesDrop
Joined
·
13,168 Posts
It's connected to itself and not the car.
 

·
Registered
Joined
·
2,484 Posts
Bad design, they should of made the plugs different so that cant happen.

What can happen will. It needs to have the plugs changed.

I mean they fill the car with sensors and all kinds of other crap to keep things safe yet they let a little thing like that slip.
 
1 - 9 of 9 Posts
Top