Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
hey guys first thread im starting [:)~] new member to focus fanatics also ,,, just recieved my ford focus 1.6 litre duratec 3 weeks ago , been doing lotsa research as to whether i have a duratec engine or a "bz" engine. Im from south africa and i duno if what you guys call a duratec engine in europe is what is considered a "bz" engine here ???

in my car manual it says that my car falls under the "1.6 litre BZ 16 V77 kw Manual Transmission" but none of that makes sense as i have not read anywhere yet on fordfanatics of a BZ engine.

pls guys help me out here and explain where im going wrong ???

thanks in advance [:)]
 

·
Registered
Joined
·
103 Posts
maybe i can help.... get the VIN number and call your dealership or even email someone at ford, they should get back to you as soon as possible. Your engine sounds like a certain model that ws made for your area, as ford has been known to do this. Make you ask them what engine this would be in american terms, as far as dsplacement etc. BZ is probably a version of a Zetec (zero emissions etc.) or duratec . You can tell the difference by where the intake is...in the back-zetec....in the front, duratec. his helps. hope t
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Than lucrative for the help on that one, reason being for the duretic question is if I decide to do few mods at least wanna know where to start . I'm guessing then my engine would be considered a duratec engine in american terms due to my intake being in front?

I'm also gonna ask as a few pointers seeing as I'm getting proper info from all you guys I've been asking around but havnt been able to get any straight answers :) a lot of websites differ on what you can n cannot do to a 1.6 litre . But what would be the worthwile mods ?

I'm a student at the moment so money is ofcourse nt growing off trees for me but I will be saving up

Any advice would be appreciated guys Thanx
 

·
Focal Distortion
Joined
·
2,332 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
sorry guys but can some one pls help i uploaded the pics onto a flickr account and then added them via the post reply to the thread and clicked on the insert image symbol and just inserted the url of the image and then clicked post reply but the image isnt displaying for me? am i doing something wrong?
 
1 - 7 of 7 Posts
Top