Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter #1
Just pulled the head off. This is what i found...



Only one question. Where did it go? There is no scaring of the cylinder walls and the head doesnt have a mark on it.



Amazingly the compression on that cylinder was just a hair lower then the rest and it ran fine?? Just one of those things i guess.

Boost Kills...
 

·
Registered
Joined
·
1,067 Posts
take your cat off and shake that piece out...lol

Damn you got lucky, must have shot out the exhaust valve and not gotten mashed.

Might wanna pull the valves out and just check for any scoring at the valve seat, but all in all, thats extremely lucky.
 

·
Focused Focus
Joined
·
6,403 Posts
The stock pistons are likely to do that if youre F/I. He is right, it is probably caught at the converter. This is a good reason why you need aftermarket pistons. Ive seen this before. Boost on a stock bottom end, the ringlands cant stand the pressure. Result is broken pistons. I dont know this "scott svt" but he is right on brother. What he has stated is correct. You got very lucky. Time to get those Ross Pistons? lol. I hope you have good luck with this man.
 

·
Registered
Joined
·
237 Posts
Discussion Starter #4
i would look in the converter if i had one... I heard a tinging noise go down my exhaust one night and that must have been it. I have been testing the limits of the Zetec for a while now. I was waiting for it to break so i could begin the build, haha.
 
1 - 4 of 4 Posts
Top