Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
wondering if anyone has had problems with the SVT DSI sticking, not due to a broken clip or IMRC motor failure?

my clip and motor both broke a long time ago, and i replaced them, and they are still fine, but i'm getting a p1519 code (DSI stuck closed) and the DSI doesn't seem to want to snap back open when i actuate it with my hand (engine off). it feels like it's sticking about halfway through.

could there be gunk built up inside the intake manifold that i can clean somehow? maybe the spring is worn out?

any help/tips appreciated.

btw, the car is an '02 SVT with 102k miles on it...still running great other than that.

thanks in advance.
 

·
Registered
Joined
·
714 Posts
Is there a spring which closes it?
Might be busted after 102k
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
actually i think the spring opens it, when the car is off or over 5000rpm.

at any rate, it doesn't work. :/
 

·
Registered
Joined
·
1,143 Posts
that must suck at WOT
 

·
Registered
Joined
·
373 Posts
Maybe the contacs inside the IMRC are hosed up... there was a how to to clean them a while ago let me see if I can find it
 

·
Banned
Joined
·
7,946 Posts
there are no springs in the IMRC motor, just little motors and cogs. is the DSI cable pinched somewhere?
you may have a faulty IMRC motor. if you have had it less than a year see if you can get it warrantied.

now, i have heard of this too. there are o-rings in the intake manifold itself. these o-rings seal the runners when they are closed. if these rings are misplaced or moved around in there, it may be causing the runners to stick. i have heard of these rings being completely removed without drawbacks.
something to ponder.
 

·
Registered
Joined
·
1,147 Posts
IMRC motor needs to be replace. mine did that.
 
1 - 11 of 11 Posts
Top