Focus Fanatics Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi everyone, I have an issue with my door locks on my 2013 MK3 focus
Front passenger side door doesn't lock or unlock with central locking.
When I lock or unlock the car, the Front Passenger side door does not click. No sound what so ever. All the other doors click.
I have taken the Lock out of the door and verified with a 12v power supply and it works.

I have attached image of the connector that plugs into the lock module.
And this is the pin layout.
Pins 5,7 and 8 are dead.
Pins 4 and 6 form a loop to see if the door is open or closed.
I'm not exactly sure how locking/unlocking relay works but it looks like connecting negative wire to pin 1 and positive wire of 12v to pin 3 locks the module. And connecting negative wire to pin 2 and positive wire of 12v to pin 1 unlocks the module. (pin 1 and 3 = lock | pin 2 and 1 = unlock).

I used a test light to test the connector for power using this wire configuration (pin 1 and 3 = lock | pin 2 and 1 = unlock) and it doesn't light up.

Also driver side rear door doesn't unlock with central locking but it locks. And I also tested this with a test light and using wire configuration mention above it only lights up when I lock the car.

There is a an issue with wiring (or central locking relays). I have no idea how relay works and how to diagnose it. or if there is an issue with wiring how would a go about testing it. There is a connector behind the tweeters on A pillars where do I find a wiring diagram for that so I can test it with a test light. I have a couple of ELM 327 USB scan tools. If I scan the car will that pick the issue with central locking control module.

In short I have issue with power locks with two doors. Front passenger-side door (doesn't lock or unlock), rear driver-side door locks but doesn't unlock. Iv'e tested the locks and they work. Issue seems to be with the wiring how do I go about fixing it?
Thanks.
 

Attachments

1 - 1 of 1 Posts
Top