Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #1
Door ajar light just came on and doesnt flicker or go out, but the dome light doesn't come on. I checked the dome light and it does work. I opened each door and pushed the sensor in all the way and the light stayed on (car running).

Is there a sensor in the trunk? (my best guess since it likely wouldnt trigger the dome) I did not see one when I checked it out. My power latch works... I mean it sounds like it's on its way out cause it sounds like dropping a bunch of BB's in a plastic jar, but it opens :/

Picked up an 06 ZX4 SE over the weekend for work commuting ~80k miles.

It doesn't really negatively affect me other than annoyance with the light constantly on, but I would like it to function normally eventually.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #2
There appears to be some numbers on the latch and I'm trying to see which I need to match up to pick n pull one.

Mine has PBT-GF30 by the FoMoCo logo and D4M4P (I need to double check that one for the M & P characters, the D and 4's are correct). I think the PBT number is the right number, the other is just a serial or something.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #3
OK the door ajar is definately the trunk. I had it off last night by opening the trunk with my insanely loud release then shutting it again and it was fine.

Today I tried a new latch from a 2010 that was wrecked and it may have been bad cause it wouldnt unlock in my hand (wire was connected), but I could hear the motor trying.

Part# PBT-GF30 appears to be right for 06-10 sedans at least, maybe more.

other numbers on mine dont seem to match up, but may be production numbers or something. N4W4D (verified its different)

Two others to check: 654A 5443282AD & 21505A1

I'll update when the one from ebay gets mailed to me.
 
1 - 3 of 3 Posts
Top