Focus Fanatics Forum banner
1 - 7 of 7 Posts

·
Registered
2007 ZX5 2.0 | 2007 ZX4ST 2.3
Joined
·
54 Posts
Discussion Starter · #1 ·
removed my tumble flaps a while back, also removed the PCV “valve” part of the valve and plugged the hole on the intake mani ie open breather . Since then I’ve ran into a very weird issue. Anything below and up to 2K rpm anytime I’m light on the throttle it will surge, and stutter, the problem goes away above 2000 rpm, or if I give it more gas.

I’m sure part of it has something to do with the tumble flap/pcv combo, (pcv was due to the concerning amount of oil/carbon combo from 160K miles) I’m solving all 3 this weekend for good. For starters I’m removing everything off my IM and soaking it in dawn overnight, also replacing the PCV and hose and adding an inline filter, reconnecting it to the intake, one of the “inserts” for the tumble flaps cracked in three pieces, two of which fit back into the mani, however there’s a gap where the gasket has no lip my assumption is that’s also part of the issue so that will be addressed.

Lastly, an impending snowstorm is calling for 16” Sunday so i’m not gonna be able to get an official egr plate from massive

My question is, would I be able to take the EGR tube on the intake side to my local parts store and match it with a bolt, and plug it that way?


Car Motor vehicle Hood Vehicle Automotive design
 

·
Registered
Joined
·
18,243 Posts
Go to hardware store for a bolt that big, no auto parts will have it likely.
 

·
Registered
2007 ZX5 2.0 | 2007 ZX4ST 2.3
Joined
·
54 Posts
Discussion Starter · #3 ·
Go to hardware store for a bolt that big, no auto parts will have it likely.
Per some UK duratec threads I think I found one, according to what they use it’s a M22x1.5 drain plug bolt. Got one last night from autozone will have to test it Saturday evening once I’m off
 

·
Registered
Joined
·
2,488 Posts
I would have thought it was a NPT pipe thread
 

·
Registered
2007 ZX5 2.0 | 2007 ZX4ST 2.3
Joined
·
54 Posts
Discussion Starter · #5 ·
I would have thought it was a NPT pipe thread
Time will tell come Saturday. I know the pipe itself has a 22MM nut to unscrew it so I’m optimistic that the brits know what they’re talking about. Regardless I disconnected the EGR valve last night and the stuttering/hesitation is almost non existent now. it still appears to be there just not as bad now, any idea what else could be causing it?
 

·
Registered
2007 ZX5 2.0 | 2007 ZX4ST 2.3
Joined
·
54 Posts
Discussion Starter · #7 ·
Have you removed it? If its NPT you should be able to see the taper.
Not yet, I had the intake off about a month ago but that was to for other reasons. I haven’t seen any mention of it being an NPT thread, unless plugs are generally that and it’s already a given.
 
1 - 7 of 7 Posts
Top