Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter · #1 ·
At first I thought it may have been a loose heat shield or something else rattling but ruled that out. If I run 87 Octane in the car and speed up fast getting onto the highway I have really bad detonation when the revs get up higher. But using 89 or 93 Octane it doesn't do this. I thought our cars were meant to run on 87?
 

·
Registered
Joined
·
818 Posts
Was your knock sensor removed?
Do you have any super dooper 700 billion hp ebay maga chips wired in any where?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #3 ·
I bought the car used so I'm not sure about the knock sensor. I can't see why it would have been removed though. And no, I'm not running an Ebay chip or anything of the sort. If only I was lucky enough to own one of those! [grinking]

My only mod is the SRI. Recently I switched back to the stock intake for a few days and it still did it but not as loud.
 

·
Registered
Joined
·
1,136 Posts
Maybe it's a hamster in the intake manifold.
 

·
Registered
Joined
·
818 Posts
Is your IAT sensor still hooked up and working?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #6 ·
Should be. I had it into the dealer about a month ago and they checked my codes and everything came back good.
 

·
Registered
Joined
·
50 Posts
At first I thought it may have been a loose heat shield or something else rattling but ruled that out. If I run 87 Octane in the car and speed up fast getting onto the highway I have really bad detonation when the revs get up higher. But using 89 or 93 Octane it doesn't do this. I thought our cars were meant to run on 87?
If you put a scanner tool on it you can check to see if it is really knock by watching the knock readings while you drive.
 
1 - 7 of 7 Posts
Top