Focus Fanatics Forum banner

1 - 15 of 15 Posts

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #1
a little while back, I posted a thread on here about a stumbling issue w/ occasional backfire.

Breifly: Under load below 3k rpms or when pulling out from a dead stop. It started out kinda minor, but over the past few weeks, it just got worse. Now it will do it up near 4k once in a while and it runs like total ass above 8k ft....good thing I live at 6k.

So far, I have changed the fuel filter, put the plug wires back to stock, spark plugs changed, cleaned & checked the MAF, reset ECU, and its throwing no DTCs.

Took it to the dealer and they called me to tell me they are starting to look at it....ok....10am. I wait to hear back and at 2pm they call to say:

"well, we have tried a few things here; checked the intake out (which is FS coolFlo), there was an update to your ECU so we reflashed it, and now it actually runs worse."

"we have our best guy on this now and he's having a hard time figuring it out, we may have to keep it overnight."

So now I am waiting it out. I have some data logs sitting here to look at, but I am a n0ob at that sort of thing....the fuel pressure seems kinda wierd to me, but like I said...I am a noob. I am hoping they will replace the fuel pump, but its doubful.
 

·
Registered
Joined
·
2,803 Posts
I'm going with you and guess at the fuel pump. The pressure doesn't have to be off by a lot to really mess up FI.
Mostly just want to wish you "Good Luck!"
 

·
BAD EGG
Joined
·
7,418 Posts
Good luck with it man...you take it to Phil Long? Dude when my fuel pump was acting up it threw code if that helps.
 

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #4
thanks guys.

yeah, I took it to Phil Long. This time on the north end, up by my house. I dont have the money for this either....I am basically taking it in to get their opinion and fix it myself cause I have no money......NONE. And my mom and sister are coming out to visit on Thurs.

talk about suck. thanks to them for making my car run worse for 100 bucks.
 

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #5
its now 4pm and I just heard from them. They are finding an intermitten failure on the #4 coil. They wanted to charge me 129 for the damn coil, and another whatever in labor...3 bills!! They would then test it and see if it works better and go from there.

I didnt authorize it. Going to bring it home and do it myself. See if it helps and hope for the best
 

·
The Librarian
Joined
·
13,116 Posts
Going to bring it home and do it myself.
[werd] on that!

Make sure you check the wiring going to the coil.
That's been known to cause the very same problem you're having...
 

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #7
yeah, I read about that and checked it out. Something about the heat breaking down the wire shielding..one person claims it caught fire! lol .... It seemed fine, but I will double check it.

thanks
 

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #8
.....let me just continue by saying that the service manager was really cool about me having mods in my car. Just wish I knew what happened to my iPod......before I point fingers I am going to check everywhere, but I am pretty certain it was in my car. I talked to him about it...noticed as soon as I got in, then called him back to tell him I couldnt find it here.

to top it all off, I went to advance auto and they gave me the part that was in their computer....but when I got it home, it wasnt the right part. uuuuuggggghhhhhh
 

·
on thin air
Joined
·
3,671 Posts
Discussion Starter #9
::: UPDATE :::

changed out my coil pack and didnt fix a damn thing. The wires that connect into the coilpack look fine.

there one less potential problem part.

anyone else wanna take a guess?
 

·
Registered
Joined
·
3,263 Posts
check ur plugs. u might have a cracked plug
 

·
Registered
Joined
·
549 Posts
its an old school method but if your car is running bad at idle as well, you can unplug one spark plug wire at a time while listening for changes in the engines sound, if you pull a wire and the car doesnt run worse, then you have found the bad cylinder...dont know what else to say.....except good luck
 

·
Registered
Joined
·
1,725 Posts
any update?
 

·
Capt. Urn
Joined
·
5,491 Posts
since your speaking of phil long, i am assuming "high altitude" means colorado....

if your in the denver metro, take the car up to sill-terhar ford up in broomfield. they have the best, and friendliest service depo i have dealt with when i lived in denver. (plus, you can drool on an aston martin or two while you wait....)
 

·
Registered
Joined
·
1,067 Posts
the Denver Automotive and Deisel college over there has one heck of a good Ford diagnostician teaching there. I can't remember his name, but I'll look around and see if I can find it. He instructed at a 2 week advanced diagnostic seminar I went to in Denver a couple of years ago.
 
1 - 15 of 15 Posts
Top