Focus Fanatics Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
548 Posts
Discussion Starter #1
I picked up my car this afternoon, been driving around the last hour and a bit, city and highway driving. It's windy and overcast.

Well I'm driving by a friends place so I decide to call him, he's about to go to work but has 5 minutes so I pull up to his driveway, throw it in park and I show him some of the car features. All while idling the car. He has to leave for work so I take off, his street is a roundbout so I spin around it and pull back onto the crossstreet and drive off. When the display starts telling me to slow and stop safely. I pull into a parking lot as the car is telling me the engine is overheating. The temp bar is full.

I give it a few minutes to cool and take off. It was breifly raining during this period so I didn't get out and pop the hood. When I get to a redlight I can slowly see the temp bar creeping back up from 1/2, to 3/4, to full again. The car was running for less than a minute so I ull over again and pop the hood. There's engine coolant splattered all over the engine bay, and the reservoir is dry. :(

Call my dealer, who passes me off to someone in the shop, who passes me off to road side assistance. And now I'm waiting for a tow to take me back to my dealer...

All smiles here.
Posted via FF Mobile
 

·
Registered
Joined
·
68 Posts
congrats on finally getting your car
 

·
Registered
Joined
·
4,328 Posts
congrats on finally getting your car
Either Stoneraven didn't read your entire post, or he has a sick sense of humor... and I like it!

Sorry about your issues! [:(]
 

·
Registered
Joined
·
2,654 Posts
sounds like youre one of many who has initial thermostat issues. sit tight, you're not the first.
 

·
Registered
Joined
·
548 Posts
Discussion Starter #5
Dealer says no hose clamp on the rad. FROM FACTORY.

Posted via FF Mobile
 

·
Registered
Joined
·
187 Posts
Heck of away to start a relationship.
 

·
Registered
Joined
·
548 Posts
Discussion Starter #7
I can see the worry in my sales rep eyes, she doesn't want to get a bad review. She's really done nothing wrong though, seems most of the problems originate from the factory.. Can I review them instead?

Posted via FF Mobile
 

·
Registered
Joined
·
251 Posts
I can't see how the robot camera that checks that hose missed the clamp not being there. wait ... who did the programming on the robot?
 

·
Registered
Joined
·
548 Posts
Discussion Starter #9
How it was missed is irrelevant, I'm just pissed off that it was missed, period.

They put 150kms on it for quality control, then the dealer put on another 20, and I put on about 70 and poof.
 

·
Registered
Joined
·
1,156 Posts
They put 150kms on it for quality control, then the dealer put on another 20, and I put on about 70 and poof.

Who exactly is "They" and what kind of "quality control" did "They" do? Hmmm [confused] Just, something doesn't sound right IMO [facepalm]
 

·
Registered
Joined
·
548 Posts
Discussion Starter #11
The assembly plant in MI.

Pretty common practice to "audit" a certain percentage of your product to ensure any defects aren't be released to the public, the car came marked with a sticker to validate the additional mileage.
 

·
Registered
Joined
·
68 Posts
mine was "chosen" for a quality test as well.... 129 km on the beastie when it arrived at the dealer. Mine has a new module ordered to resolve the MFT issues....indexing, clock resetting, and a couple other minor issues. Nothing like yours though.
 

·
Registered
Joined
·
92 Posts
...and after all the quality control, dealer looking over it...

They still missed a simple clamp??
 

·
Registered
Joined
·
548 Posts
Discussion Starter #14
yup!
 

·
Registered
Joined
·
548 Posts
Discussion Starter #15

empty reservoir, splatters of fluid all over the engine bay.


no fluid


splatter on the hood lining


getting picked up


:(


20 cent part and a fluid top up later and she's running.
 

·
Registered
Joined
·
92 Posts
Are they going to clean the engine bay for you?
 

·
Registered
Joined
·
154 Posts
How long did you wait for your car? I don't recall.
 

·
Registered
Joined
·
533 Posts
Hi, I think that all you guys having these QC issues number so many now that something should be done by Ford at the factory to address this. Over in Europe we don't seem to be having the same, it s unbelievable that a clamp is missing.
Chris
 

·
Registered
Joined
·
548 Posts
Discussion Starter #19
I waited 12 weeks for my car.

They missed catching shit in both the "additional road testing" and during PDI.
 

·
Registered
Joined
·
472 Posts
I waited 12 weeks for my car.

They missed catching shit in both the "additional road testing" and during PDI.
you have to remember, MI is one of the "lands of perpetual winter" so your car prolly didn't get hot during the test drive LOL! I also kind of doubt they have stop lights on the track or whatever.

I will say this .. it sux when you are the one that gets the missed part, but in reality it is a small percentage of cars that have this kind of thing happen. but when you are the one it happens to that is little, if any, consolation [cheers]
 
1 - 20 of 23 Posts
Top