Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

New owner of a 2008 Ford Focus Manual trans here, just wanted to scope the community's knowledge before I dump some money at the dealer.

First off, I have just the odometer with a trip reset button. Since I've bought the car, for the life of me I cannot figure out how to get it to display in miles. It is stick in kilometers, and I've called two dealers, google searched, etc and I cannot find out how to switch it back. My dealers answer - bring it in and we'll figure it out and charge you. Seems silly, anyone have any clue? I tried disconnecting the battery and still it will not switch back.

Secondly, when I shift from 1st to 2nd, it seems like its getting stuck in first. And sometimes its hard to get into gears, other times it is easy. Is the transmission on its way out (60k miles) or is there another alternative?

I have a tire pressure sensor light on... any ideas on how to figure out which tire it is?

Thanks in advance for anyones help! Proud to be a member of the community.
 

·
Registered
Joined
·
652 Posts
Hi all,

New owner of a 2008 Ford Focus Manual trans here, just wanted to scope the community's knowledge before I dump some money at the dealer.

First off, I have just the odometer with a trip reset button. Since I've bought the car, for the life of me I cannot figure out how to get it to display in miles. It is stick in kilometers, and I've called two dealers, google searched, etc and I cannot find out how to switch it back. My dealers answer - bring it in and we'll figure it out and charge you. Seems silly, anyone have any clue? I tried disconnecting the battery and still it will not switch back.

Secondly, when I shift from 1st to 2nd, it seems like its getting stuck in first. And sometimes its hard to get into gears, other times it is easy. Is the transmission on its way out (60k miles) or is there another alternative?

I have a tire pressure sensor light on... any ideas on how to figure out which tire it is?

Thanks in advance for anyones help! Proud to be a member of the community.

Not sure on the ODO.

I switched to synthetic trans fluid and it made a huge difference.
http://www.c-f-m.com/performancepar...etec-SVT-ST170-Duratec-p1499.htm#.VLsB-DmRg5Q


Go and manually check the tire pressure of each tire to see which is low...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Not sure on the ODO.

I switched to synthetic trans fluid and it made a huge difference.
http://www.c-f-m.com/performancepar...etec-SVT-ST170-Duratec-p1499.htm#.VLsB-DmRg5Q


Go and manually check the tire pressure of each tire to see which is low...
Thanks! I am going to try that fluid for sure tomorrow. I appreciate it. As for the tire pressure, they are all at correct PSI - i was just wondering which sensor was bad and causing the light to be lit.

Check out this thread. Your question about the ODO has been brought up before.

http://www.focusfanatics.com/forum/showthread.php?t=311433

- On a side note, welcome to FF! I'm sure you'll love the community here!
Thanks. I read that thread a few times, but it still is unanswered. I have a 2008 Focus with the LCD screen in middle of dash, not the color dash. There is no menu button, or way to change language, or distance type.
 

·
Registered
Joined
·
652 Posts
Thanks! I am going to try that fluid for sure tomorrow. I appreciate it. As for the tire pressure, they are all at correct PSI - i was just wondering which sensor was bad and causing the light to be lit.



Thanks. I read that thread a few times, but it still is unanswered. I have a 2008 Focus with the LCD screen in middle of dash, not the color dash. There is no menu button, or way to change language, or distance type.

I would recommend getting a hand pump to pump the fluid into the trans. It was a huge PITA trying to get the fluid in without one..
 
1 - 5 of 5 Posts
Top