Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #1
Here is the problem I am having, my car last time I was at the track ran a 10.8 1/8 mile and that was with intake, exhaust, TB, and Eibach springs. Something doesn't seem to be exactly right with the TB because the throttle response doesn't seem to be exactly right at quick blips at the throttle.

My question is, do you guys think I should take my TB off before the track run this Friday to see if there is a problem with it. I had about a 160 pound passanger with me also so do you think if that person wasn't in the car with me I coulda ran faster???

There was a guy that ran a 10.1 with his BONE stock ST and here I am running a 10.8 with intake, exhaust and TB... I really need help with this... so can someone help...LOL[:D]
 

·
Registered
Joined
·
7,414 Posts
can you switch it out inbetween runs? it took me less than 10 min. to switch mine.

although you have one of those goofy duratecs that has the intake on the wrong side
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #3
well I don't think that the TB will really make me faster but I VERY sure that it could possibly slow me down because the cars computer isn't taking to it or something, next on my list is a tune.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #4
I probably won't be changing it out during runs... I can but don't really want to...
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #6
by dis-connecting the battery??? Yes I did and so did my dealer... but it still isn't exactly right... I think I should switch it out for stock. What kinda affects start when somebody poors sugar down the gas tank???
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #9
No it's not broken.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #10
cruzstyle said:
i ran a 10.8 in my foci this weelend and i only have a cat back and a home made SRI and yes the person in the car wis slowing u down
yeah but I have an ST and another person in a STOCK ST ran a 10.1 and I have an intake, TB, exhaust, and STS, and of course suspension.
 

·
Registered
Joined
·
1,660 Posts
dosen't a tune help the mods make beter gains so the computer is sinked with the mods? I know they say you don't need a tune but it has got to help I say tune it and see
 

·
Registered
Joined
·
930 Posts
Throttle response on a duratec, even with the throttlebody, won't be quite like a hayabusa. It will still be kinda lagged anyway, just the nature of the beast.

Ditch the passenger and you should be able to run a lot better. I can tell a difference in the way my car drives with a passenger. These cars are quick cause they are light, so the 160lbs was making your car quite a bit slower (that is like 17% of your curbweight, added to your curbweight plus gas and you!).
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #13
But do you think I should take the TB off just to see if it helps ot should I get just keep it on... is there a way it could be slowing me down???
 

·
Scuba Edition
Joined
·
1,694 Posts
do two runs with it on then take it off and do two runs with it off. Then, compare.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #15
I might not be able to change them out though... I don't want to do so trying to do it quickly.... I don't want to break something.
 

·
Registered
Joined
·
930 Posts
WickedlyFastST said:
But do you think I should take the TB off just to see if it helps ot should I get just keep it on... is there a way it could be slowing me down???
If you have your throttle cable on good and it actuates and returns without jamming or something, I doubt it is the cause. I could be wrong of course, but I bet it is prolly ok.

Only way to know is to swap them and see...should take about 5-10min if you take your time...be sure to cover the intake entrance with a rag or something though!..lol.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #17
There is something wrong with the cables... when I am off the throttle... the cable bends... like it isn't returning right... do you know what I mean???
 
1 - 17 of 17 Posts
Top