Focus Fanatics Forum banner

1 - 20 of 28 Posts

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #1
Alright guys i gotta get this out....so after a 8 install on my Cosworth IM its done, but no lie this thing is not for the weak hearted and impatient.

I figured as much when i bought it, but for the most part for the price i thought id be recieving A++ everything. But not so much. The instructions were OK a lot of stuff they said to add to the Mani when it was already on the car could have been added when it was off the car and it would made my life a lot easier. Thanks to warneej he gave me a couple pointers like takin the nose off and it made things go a lil smoother. (thanks again)

The parts they provided were nice, but i dunno if it was just my experience but i was missing some! i was missing a gasket and a bolt...luckily the gasket from the old one fit decent enough and i ended up having a bolt that fit the MAP sensor so i lucked out there.

A part that really bothered me were the gaskets to the block...the stock ones put them to shame, they give thin lil o-ring type which i dont even know how they seal. Im prolly gunna be taking it off again and putting new seals that fit better. Also i ended up going to the parts store and picking up brass fittings for the brake booster line cause they give a straight hookup...but my stock line was too short so i picked up a 90 and made a custom fit, that even didnt really bother me cuz i figured some stuff would need modifying...

well anyway im done b!tchin im tired...heres what it got me, all said and done....it sickkk [strongman]
 

·
Registered
Joined
·
1,929 Posts
so how does it feel?
 

·
Registered
Joined
·
1,243 Posts
The manifold o-rings are fine they just dont sit inside the groove as far as the stock ones. Mine came with all of the parts and as for all of the fittings I put them on first. What gasket were you missing?
 

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #5
so how does it feel?
i honestly finished cleaning everything up and stuff at like 10:00 so i didnt bother taking it for a ride...besides im loading the tune on tommorow so id rather wait for the tune anyway

The manifold o-rings are fine they just dont sit inside the groove as far as the stock ones. Mine came with all of the parts and as for all of the fittings I put them on first. What gasket were you missing?
that fifth round one next to either the first or last runner i dont remeber right now...
 

·
Freeskiing Fanatic!
Joined
·
5,455 Posts
it may be a rant, but look at how it looks in the engine bay. It just makes me smile at how awesome it is. You cant be angry when there is a big block that says Cosworth on it staring up at you.
 

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #8
it may be a rant, but look at how it looks in the engine bay. It just makes me smile at how awesome it is. You cant be angry when there is a big block that says Cosworth on it staring up at you.
haha i know i was thinking that when i was cleaning up...its like a damn puppy u just cant be mad at haha...except it just looks a lot meaner lol
 

·
br/o/stang
Joined
·
5,563 Posts
sir, I envy you.
 

·
BodyKits=PantiesDrop
Joined
·
13,168 Posts
i had some of those problems, the gasket you were missing is the one for the EGR tube, i was missing it too, the runner gaskets i had to glue in with some RTV to hold them on, EVERY SINGLE fitting cross threaded when i screwed it in, its like the threads in the aluminum were a different pitch then the fittings they gave, and some of the bolts (specifically the ones for the IAC) were too long for the holes.

We figured out while putting it on that we should hook everything up before bolting it on, contrary to the instructions...sorry i didn't tell you that stuff, i assumed that these were isolated to my run of IMs or something...

and i'm jealous of your polished "power by cosworth" plate...mine didn't come that way [:(]
 
  • Like
Reactions: mtadd162

·
Registered
Joined
·
1,243 Posts
Did you buy yours a long time ago. I have had mine for like 2 years and it says "PBC" too? Thats the best part of the IM! I want an extra one to hang up on my wall!
 

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #12
i had some of those problems, the gasket you were missing is the one for the EGR tube, i was missing it too, the runner gaskets i had to glue in with some RTV to hold them on, EVERY SINGLE fitting cross threaded when i screwed it in, its like the threads in the aluminum were a different pitch then the fittings they gave, and some of the bolts (specifically the ones for the IAC) were too long for the holes.

We figured out while putting it on that we should hook everything up before bolting it on, contrary to the instructions...sorry i didn't tell you that stuff, i assumed that these were isolated to my run of IMs or something...

and i'm jealous of your polished "power by cosworth" plate...mine didn't come that way [:(]
omg yes i was soo scared of stripping almost everything that bolted in...it was so hard, how did ur iac valve bolt in...the bolt closest to the TB i had to trim cause it was too long and the my throttle would hit it
 

·
Registered
Joined
·
1,243 Posts
I had to trim the bolts for the IAC too. But thats cause I have cruise control and the plastic connector was hitting it. I think I used different bolts for it, they were stars, just dont remember where they came from.
 

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #14
yea i have cruise too...well right now i dont cause i have to customize to make that plastic peice fit...but im not really worried about it cuz i never use cruise
 

·
Registered
Joined
·
1,243 Posts
I found another connecter off like a f150 that im gonna try to jb weld to the end and see if it will work. Once you put the IM on the cable is like 1/4-1/2" short.
 

·
Proudly Daily Driven
Joined
·
2,255 Posts
Discussion Starter #16
really, its short too...hmmm thats dissapointing
 

·
Registered
Joined
·
1,243 Posts
Not to sure about the stock TB, but I think Egz or Jet had the same problem with the stock one. I guess the IM is just a tad longer than the stock one. I am just mad that you cant adjust the CC cable, its only like 1/4 off. I tried everything and now its just disconnected till I can rig up that f150 clip.
 

·
BodyKits=PantiesDrop
Joined
·
13,168 Posts
Did you buy yours a long time ago. I have had mine for like 2 years and it says "PBC" too? Thats the best part of the IM! I want an extra one to hang up on my wall!
forgot about this thread...oops...i bought mine last august, and it does say PBC, its just not polished, its textured like the rest of the IM

as for the CC, mine was only a few mm short and caused the throttle to stay open just a tad so we hammered on the bracket until it was in the right position

i went and bought different bolts too so i could keep the CC hooked up, works perfectly!
 

·
Force-Powered Focus
Joined
·
6,877 Posts
manoman, cosworth knows how to make peices look GOOD and MEAN! hows it running? hows the mpg?
 
1 - 20 of 28 Posts
Top