Focus Fanatics Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
584 Posts
Discussion Starter #1
Hey everyone,

Just got my cossie intake with 67mm TB installed. It's running way faster so I'm happy with that, but I'm also getting a CEL, hanging revs, and somewhat rough idle. To anyone with those mods, is that normal? This is the 1st I've heard of this.
 

·
Registered
Joined
·
1,948 Posts
Check all your connections, sound like the MAF might not be connected. Also reset your ecu (disconnect battery wait 10 min)
 

·
Registered
Joined
·
584 Posts
Discussion Starter #3
Battery was disconnected during install for at least an hour so the ECU should be reset. I will check connections again. Could the MAF be upside down or something?
 

·
Registered
Joined
·
584 Posts
Discussion Starter #5
I just went out and looked under the hood -- connections seem to be fine. Nothing is lose or disconnected.
 

·
Registered
Joined
·
584 Posts
Discussion Starter #6
The hanging revs hang for maybe 30 secs at idle then it goes down to about 1k idle but it's still a lil rough.
 

·
Registered
Joined
·
1,158 Posts
battery reset doesn't work from what i know on the cossie manifold. You'll have to get a decent tune. The design of the manifold is a heck of alot different, so I doubt the computer can adjust. More air = Need for more fuel
 

·
Registered
Joined
·
584 Posts
Discussion Starter #8
It's the cossie intake (CAI), the not the cossie manifold, dude.
 

·
Registered
Joined
·
584 Posts
Discussion Starter #10
P0507 Idle Control System RPM Higher Than Expected --that's CEL code I get according to my xcal. Suggestions?
 

·
Registered
Joined
·
373 Posts
TB gasket... maybe a small leak?
 

·
BodyKits=PantiesDrop
Joined
·
13,168 Posts
sounds like maybe your TPS is in wrong
 

·
Registered
Joined
·
25,627 Posts
Yup^^ I would check and double check the TPS position on the new TB ( sorry I was busy with other stuff), also a small air leak would cause all that. With the car idling, spray some carb clean or brake clean around the base of the TB and see if the idle changes
 

·
Registered
Joined
·
0 Posts
I know I remember checking out your cosworth before the install and everything looked fine with that, now did you and chaz make sure everything was tight on the cossi and on the TB? Also with having to stretch the piece connecting to the TB from the Cossi did anything rip or tear?
 

·
Registered
Joined
·
25,627 Posts
^^^ Good point, I got that rubber boot on without tearing it, but there could be a small gap or airleak there, I would check that as well for a leak..
 

·
Registered
Joined
·
584 Posts
Discussion Starter #18
I'll check all those things guys. I'm having my Stang worked on, this coming Friday at a Ford specialty shop. I'll see if they can throw the focus in there to maybe take a peek and find out what is wrong.
 

·
Max8
Joined
·
2,858 Posts
Not to my knowledge, no.
If you have the cosworth I believe you can actually do it. I'll post a pic with the torx bolt that can be adjusted.




I haven't tried myself but it looks that it can be adjusted that way.
 

·
Registered
Joined
·
584 Posts
Discussion Starter #20
I don't have the cosworth TB, I have the FC TB.
 
1 - 20 of 20 Posts
Top