Focus Fanatics Forum banner

1 - 14 of 14 Posts

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #1
I installed my cossie Tb today and for some reason it is acting funny. Now I am about to explain something kinda long but I would appreciate youe help if you can.

lets say I am traveling at 40 MPH and the light up ahead turns red. I don't always down shift, a lot of the times I just press the clutch and smoothly come to a stop. Well with my stock TB it would stay at 2000 RPM's til I came to like 20 MPH and then drop to idle RPM like 750. Now with the new TB it stays at 2000 RPM's until I ALMOST come to stop but it is VERY noticable to me and the others around me that it is idling high when before it never did this. Then after it drops from 2000 RPM's when I stop, it idles at like 1000 RPM's for about 3 seconds and then it drops to 750 RPM's like a sensor kicked in or something. Very weird caseu this never happened before.

I am asking you guys to please help me out here because I need to know if this is normal or if I have to do something about this. I thought tomorrow I would dis-connect the battery for like 30 mins to see if that would fix the prob... please let me know whats up.

Thanks[:(]
 

·
Registered
Joined
·
1,395 Posts
from what i understand, you kinda have to disconnect the battery when you put a TB on so the ECU can adjust.

and from my own experience installing an FC TB, make sure your TPS sensor is still hooked up. mine did the exact same thing you described until i got that corrected. good luck!
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #3
You had the same issue and what fixed your issue?
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #4
I know my TPS is hooked up because I dunno about the FC but the cossie one comes with it's own bolts to hook it up so how could it come out?
 

·
Registered
Joined
·
1,395 Posts
my issue was that i didn't realize what the two bolts that came with my TB were for until i had already tried to use the stock ones [?|]

but the TPS obviously isn't your problem, so i dunno... maybe the idle adjustment screw needs to be adjusted? i've heard people talk about that, and it seemed to fix some of their problems w/ a new TB
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #6
true but if it was off in my opinion it would stay idling at 2000 RPMs... wouldn't it?
 

·
Registered
Joined
·
1,395 Posts
i'm not sure, when i put my TB on (and the TPS on CORRECTLY) it idled just fine, i didn't have to adjust anything. you might try it to see if it helps
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #8
I will dis-connect the battery first to see if that works because I don't wanna mess with something I don't have to.
 

·
Dragon Warrior
Joined
·
309 Posts
i agree you have to reset the computer every time you do an engine mod.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #11
ok I reset the computer and well yes it helped a little but it still does the weird idle.
 

·
Premium Member
Joined
·
21,246 Posts
I wouldn't recommend playing with the throttle plate adjustment screw, but so long as you follow good procedures you should be fine. I'd probably do it if it was my car. You'll need something to mark the screw and the TB for reference black sharpie, silver sharpie, color marker, knife blade, etc. Just so long as you can mark your starting point. Then turn the screw about 1/8 of a turn to close the throttle plate further. Remove your negative battery terminal before starting the adjustment, and then re-install afterwards. When you start the engine allow it to warm up, then rev the motor to a steady 2k rpm for 10 minutes. This should cut down on the re-mapping time on the road. Test drive, and see if you still have the problem.

I hope this helps Sharon [thumb]
 

·
Registered
Joined
·
722 Posts
Are you still using the stock intake manifold? If so, it is my understanding that the Cossie TB is designed only to work with the Cossie intake manifold, not a stock one
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #14
I know many other people who have a cossie TB with the stock manifold.
 
1 - 14 of 14 Posts
Top