Focus Fanatics Forum banner

1 - 8 of 8 Posts

Registered
Joined
6 Posts
Discussion Starter #1
My 03 SVTF needed a new clutch wo i replaced it car would start but onkynfor a few seconds compression was on the lower side while checking the timing found the engine was very difficult to turn over by hand. Pull everything back apart the side of the clutch the was supposed to slide over the spindle didnt. Thank full was able to get a different clutch to try but same issue. When the engine is apart from the trans it spins fine and the trans spines fine once i put them together though i need a 3 foot braker bar to turn it over. I feel like something is obvious wrong in the clutch area. Im not sure but if anyone has an answer i would be so grateful! Really want to finnish this up befor winter ao She doesnt sit like this all winter

Thanks a ton for any suggestions!
Isaac
 

w/ my magic bag
Joined
29,394 Posts
I take it the motor ran great before? What clutch did you use? Did you also replace the flywheel? How 'bout the throw bearing? Did you go w/ a d/m oem style or a one piece aftermarket flywheel type?
 

Registered
Joined
6 Posts
Discussion Starter #3
Just resurfaced the flywheel, Motor ran just fine befor! got an oem clutch everything fit up well
 

Registered
Joined
6 Posts
Discussion Starter #5
Would the flywheel be causing the problem? the shaft on the trans only slides into the clutch right?
 

Registered
Joined
6 Posts
Discussion Starter #7
Did bot replace the bolts engine turns over fine without the trans on but with the clutch installed
 
1 - 8 of 8 Posts
Top