Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,548 Posts
Discussion Starter #1
Hey guys, I recently bought a 2012 Focus as a daily driver and it has a front end clunking noise. I changed the front end links and the noise continued so I suspected the front strut bearings however there is no noise when I turn the wheel lock to lock while stopped so I don’t think it’s the strut mounts.
I went on to change the upper and lower engine mount as well as transmission mount and the noise continues.
Any recommendation on what I should be looking at next?
I can try to post a video of the noise if needed.
Thanks
 

·
Registered
Joined
·
494 Posts
I would jack the front wheels up and try moving the wheels around while watching the various suspension parts looking for excessive play. Do the same with all of the front suspension parts, focusing on all the joints. Could be a loose ball joint, tie rod end or a bad bushing.
 

·
Registered
Joined
·
15 Posts
How many does it have? And I agree with what IrishBrewer said. Diagnosing correctly will save you some time and probably money.
 

·
Registered
Joined
·
27 Posts
Check you lower control arm bushings.. This was a big issue with early MK3’s, had to replace mine myself at 75k miles and should have been done a lot sooner. If the rubber bushings are cracked they need replaced
 

·
Registered
Joined
·
219 Posts
I like my Mk2, 2010 SES, but my main complaint is there is always something clunking or rattling in the front end needing replacement! I've come to accept that even if you get one noise to go away, you'll start hearing another one, or one will come within a couple months. Sorry for the rant.
 
1 - 6 of 6 Posts
Top