Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
I installed my frpp 1.5 kit on my 08 a little over 1,000 miles ago and had no problems since, until now,
Driving normal roads are fine, until I hit a bump and then I hear a loud "clunk" from the front.
Checked it out and couldn't find anything loose. But I did notice that when I turn the steering wheel the strut and spring move side to side[:0] , is that normal?
I re-torqued the the big nut on top along with the strut tower bolts and everything was in spec so.....[scratch]
 

·
Registered
Joined
·
54 Posts
Check the bolt on the knuckle that attaches to bottom of the strut. I believe it is a 18mm bolt. Use a breaker bar to tighten.
 

·
un1corn
Joined
·
2,703 Posts
If the strut assembly is moving you should check your strut bearings and mounting plates to make sure the aren't worn out. Sometimes the bearings can stick or just not work and cause crazy issues.
 

·
Registered
Joined
·
1,929 Posts
I installed my frpp 1.5 kit on my 08 a little over 1,000 miles ago and had no problems since, until now,
Driving normal roads are fine, until I hit a bump and then I hear a loud "clunk" from the front.
Checked it out and couldn't find anything loose. But I did notice that when I turn the steering wheel the strut and spring move side to side[:0] , is that normal?
I re-torqued the the big nut on top along with the strut tower bolts and everything was in spec so.....[scratch]

I get that same clunk, it almost sounds like a bump stop clunk.

I've checked everything myself aswell.

Are there internal bump stops on the front, or am I just blind?

It only happens over one bump by my house, it's where they patched the road so it's kind of like a mini-speed bump, and the speed limit is 40 so it does hit kinda hard. I usually try to slow down though.
 
1 - 5 of 5 Posts
Top