Focus Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey guys

Really need your help with this one. I have a focus with a 2.3l and I live up in good ol snowy Canada. My check engine light has been coming on and off as of late. Just wondering if it may just be that fact that I may have a bad connection somwhere, or maybe it's just a sensor. Regardless it makes me wonder if something is really wrong here. I tried having a look at the codes that you can get off the dash board, but I am not a pro at reading the codes. Can anyone help?[?]
 

·
Registered
Joined
·
1,484 Posts
hmm...if it's turning on a off, it sounds like it could just be a loose or bad connection.

Have you done any mods to your focus or is it completely stock?

Have you tried restarting the computer in your car? That might help...
 

·
FoFo Lover.
Joined
·
2,884 Posts
Mine comes on and off. But it's because I have a bad O2 sensor.

It's probably something as simple as that.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Hey Matt

No the car is completely stock. You may be right by saying it's a loose connection. Not too sure on what or how to restart the computer from the inside. Can you please explain

thanks
 

·
Registered
Joined
·
1,484 Posts
unplug the battery completely and leave it unplugged for about 20mins. this will reset the computer on your car. this might help.

by chance, do you have a CAI or RAI on your car?
 

·
Registered
Joined
·
3,487 Posts
Simply buy a code reader, or go to a parts store that reads codes for free. The code that's flashing on/off should be stored in the memory, even if it's off when it's read. It's completely stupid to guess about such things. You can spend a bunch of money throwing parts at a problem....
 

·
Focus Hoarder
Joined
·
3,633 Posts
CAI = Cold Air Intake
RAI = Ram Air Intake

and the codes on the dashboard are not from the cars computer the codes stored within the clusters LCD belong to the onboard Cluster diagnostics, the codes if it has any refer to problems with the cluster itself..

to read the codes the Check engine light is causing you will need to take it to Parts Source, Candian Tire or any parts store and ask them to read it, or you can buy yourself a cheap OBD (On Board Diagnostics) Code reader from any parts store

Depending on which light is actually flashing will refer to something either simple or serious.. the focus actually has 2 error warning lights, the engine light and the Exclamation (!) light if the exclamation is blinking thats as severe as its going to get, if the engine light is blinking that can be caused by a number of things including overheating, continuous errors that will have ill effects or misfire on the sparkplugs
a solid warning light means theres a code stored for a part that showed out of range but is not in dire ( desperate) need of checking right away but there is a problem that has to be checked and rectified

without the actual codes I cannot determine the severity if your problem
 

·
Focus Hoarder
Joined
·
3,633 Posts


this is just a reference ( this cluster is the stock non tach ) the one with the tach has the lights in different spots
 

·
Registered
Joined
·
872 Posts
The '05s don't have the exclamation light. Could be a bad connection, but it's more than likely genuine. To clarify.......the engine check light has come on "steady", but not on every trip? And it doesn't blink? And the car is performing OK? If the answer is yes, then you don't have to panic. As suggested, get thee to a CT and get the code read, Or, buy one of the inexpensive code "readers". CT very often has them on sale.
 

·
Focus Hoarder
Joined
·
3,633 Posts
XD then ignore the parts with the exclamation... I didn't know they snubbed that light in the 05+'s

with fords bright idea on using real cheap wires that were never rated for outdoors and break I somewhat agree with Grumpy if the light is steady but comes and goes at random intervals it may be just a loose connection

I'm going to leaving the picture in case someone in the future with that style light setup experiences this problem tho
 

·
Registered
Joined
·
3 Posts
Hi,

Please i really need your opinion because yesterday my ObD indicator flashed for 30 second and then turned off again....i feel problem when i push the gaz..its like taking the speed not constantly....

I think its related with bad fuel...what shouuld i do??

i m using focus,1.6 Petrol 2010
 

·
Premium Member
Joined
·
21,250 Posts
That is something that will do that. If I were you, I'd start my own thread instead of posting in a 4 year old thread. The date of the posts are in the left hand corner of the dark blue line above the post. That will get you more answers. We'd also like to know if you can find out the DTC (diagnostic trouble code) that is stored in the engine's computer from this. That would be helpful in diagnosing what is wrong.
 

·
Registered
Joined
·
3 Posts
Sorry for that.....

On the dashboard of my focus there is not any message available... it say " no message"

From yesterday the OBD indicator light has not flash....

Do you think putting adding new petrol and putting a petrol cleaner inside will be a good idea ??because i believe it is related with bad fuel i putt 2 weeks ago..
 
1 - 16 of 16 Posts
Top