Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
was out with a few a friends tonight, got in the car to come home and the chek engine light was on. only 'bout a 5 minute drive home, but by the time i got home there was a pretty strong smell of sulfer in the car. the idle is a bit chuggy when you first put it in gear. this just started tonight... any ideas what it could be? I know the obvious answer is to take it to the dealer to get the code, which i will do, but i cant do that till tomorow, and i'm a tad worried.... it is about -20 here tonight, but i dont think thats got anything to do with it since its warmed up from about -30 the past couple of weeks..
 

·
Registered
Joined
·
816 Posts
Smells like sulfur? Don't catalytic converters smell like that when they go bad? Maybe that's what's going on. Although I have never heard of this in so new of a car.
 

·
Registered
Joined
·
732 Posts
Take it to a shop and get it scanned, don't wait untill it shuts off. Just get it scanned and find out what's wrong and get it fixxed.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #6
went into today, i cant get it in to be looked at till monday morning. It has been runnin pretty wierd since last night. the idle is really low (light are dimming) and when driving it gets really chuggy, for lack of a better descripter. it doesn't seem to get chuggy at a certain speed or rpm, but it does seem to be one spot on the pedal, about half way down.... if dont push the pedal down to that spot, its fine, or if i keep goin down past that spot its fine... but right in the middle the whole car chugs really bad...
 

·
Registered
Joined
·
732 Posts
hmm wierd. thats wut my car was acting like. My MIL light came on about a month ago and started the car started to act like that. Does your take off suck? Also, do you have a aftermarket intake or something cuz I found out that mind went on because a clamp on on my intake loosened up and screwed up the MAF which made the fuel run rich and that clogged my cat up.
 

·
Registered
Joined
·
1,494 Posts
batteries smell like sulpher, if you are having electrical problems (ie lights dimming) it's probably something battery related. No need to go to the dealership, most autoparts stores can scan your codes for you for free.

g
 

·
Registered
Joined
·
571 Posts
Discussion Starter #9
yeah, take off sucks ass (like worse than normal, damn atx...). i dont have any aftermarket engine components as of yet... i took it to a friend who works with cars yesterday, and he said he thought either a short or the alternator, both of which should be covered under the warrenty when i take it in on monday. this morning when i went to drive to work at 5am, i turned on the headlights and both bulb promptly blew out (new bulbs that have been in for about a month...). so that kinda makes me think short, but could a short that would cause the headlights to go out effect the engine or the idle? also, it was only the low beam filiment that blew, brights and the fogs are fine...


guess this is what i get for braggin to a friend that i have never had any trouble whatsoever with the focus...[?|]
 

·
Registered
Joined
·
4,326 Posts
for the engine to chug when driving is caused from the CAT going bad..


to think about it, it might be your CAT, which will cause the engine not to breathe right and may cause your car to want to stall because to much fuel is in the engine and the air isnt getting out there for changing your idle rate. get that checked out..

you can take it to autozone to get the code checked out for free.
 

·
Registered
Joined
·
148 Posts
mine comes out from time to time but not very often. My mechanick check it and said that this may happen when I reach 7k rpm
 

·
Registered
Joined
·
4,779 Posts
Bolan said:
mine comes out from time to time but not very often. My mechanick check it and said that this may happen when I reach 7k rpm
What comes out from time to time? You cannot get to 7000 rpm unless you have the rev limiter removed.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #14
well, they said it was just the spark plugs and wires needed to be replaced (of course they're gonna say its somthing not covered by warrenty..) so they replaced those, and $200 later, the car is the worst its ever been. it was fine for about 5 minutes goin through town(actually it was peppier than it had ever been), but as soon as i hit the highway, the engine light started flashin and the car bogged right down... headin back over in the morning to rip 'em a new *******...
 

·
Registered
Joined
·
919 Posts
Sorry to hear it man, it always sucks to hear a dealer ship try and put it to some one where the sun dont shine. My wife has the new GTV6 Tiburon with the 6 speed and the dealer ship tried to screw us pretty good. They removed the tranny and droped it on the drive shaft. [?|] We took it home with the drive shaft bent... car wobbled all over the damn road. Took it back to em and they tried to say it was our fault. We threw a fit right there in the service department[mad] . They fixed it but We'll never go there again. For any warenty problems we drive to the next town to have it looked at.
 

·
Registered
Joined
·
60 Posts
ok u say it boggs down ? mine bogged down when the MAF was goin out bc i ran none day becaze i washed it and waited for it to dry ran to much air and CEL came on autozone said it was insuficient airflow so i replaced MAF and hasnt done it since, but the sulfur smell is wat get me im think the cat is stopped on that one
 

·
Registered
Joined
·
1 Posts
I had an 2001 ford focus SE and i had a similar problem that happened twice. The check engine light came on and the car started sputter. It would sputter only at a certain spot on the accelerator. Lights would dim, car ran like crap, but i did not smell any sulfer. I took it to the dealer (under warranty) and they replaced the exhaust sensor. I dont know exactly which one it was, but it fixed the problem. This happend after six months of owning the car. Then the same problem happend again six months later! As for the headlights shorting out I have no clue.
 
1 - 17 of 17 Posts
Top