Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
First time poster here, wish it wasn't because I had car trouble!

I have an '03 SE (2.3L DOHC) and the check engine light just came on, the engine kinda sounds like it's slipping or not getting into gear. It also revs itself while idle. I thought it was just the timing belt before the light came on, and I was being really lazy and not replacing it...now I'm thinking its something worse.

Anyone else had this problem or might know what's wrong? If it's something cheap and easy I'll either do it myself or take it to my guy...but if you think it's something that's going to be expensive it's going to have to go to the dealer for warranty work (trying to avoid that, every time I go to the dealer I get a new car)

Thanks for your help :)
 

·
Registered
Joined
·
575 Posts
Go to Advance Auto Parts or Autozone and they will scan your computer for free
 

·
Registered
Joined
·
9,084 Posts
Only way to tell forsure is to have it scanned. Could be a number of things but without a code it's impossible to say for sure.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well, I guess the Autozone by me is no longer scanning. I did go into the onboard diagnostic mode (found that from this forum, you guys rock) and it wasn't showing any codes (it said "dtc: none"...I assumed that was where it should've shown a code).
 

·
Focus Hoarder
Joined
·
3,633 Posts
The Cluster Code reader is for the onboard diagnostics for the cluster alone it won't read the main cars computer for codes

do you have any other local shop like pepboys or any other retail parts supply store???
 
1 - 6 of 6 Posts
Top