Focus Fanatics Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
My check-engine light has been on for quite sometime now...

Since it has come on, the car has been getting much worse gas mileage. Every OBD II scan has shown codes related to the O2 sensor.

So far I have...
-replaced the O2 sensor twice with third-party brands
-replaced the O2 sensor with the OEM model
-replaced the pig-tale (connects the sensor to the wiring harness) with the OEM sensor installed.
Unfortunately I didn't provide the exact codes. I should be able to if necessary.

Also, the car tends to have a very unresponsive throttle for a bit when moderately warm.

Please assist me in solving this problem is you can.
 

·
FF Cleaning Squad
Joined
·
11,959 Posts
My check-engine light has been on for quite sometime now...
And this forum has been SVT performance chat/owners lounge for even longer, please post threads like these in technical chat.


Moved.
 

·
Registered
Joined
·
872 Posts
A scantool/code scanner can be your best friend......scan for codes as your next troubleshooting step and before throwing any more parts on this car.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 ·
I scanned before purchasing each part.
______

Thanks, I'll check the fuse.

I feel like the chain auto-shop that I went to first, tampered with the car...
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top