Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
The check engine symbol appeared on the dash board, and a repair shop read the code as PO128. Is it something to do with the temperature sender? Where is the temp. sender? Is there more than one? The car is a 2007 SE 2.0 PZEV manual trans. How is the sender(s) tested?
 

·
Premium Member
Joined
·
44,595 Posts
You can read the DTC's here:http://www.focusfanatics.com/forum/showthread.php?t=59286 (a stickie in the How To section)

You'll have to look far down the list to find it, this one doesn't come up very often.

The PCM isn't seeing sensor readings come up to normal operating temps while driving, so it's warning that the thermostat is probably stuck open.

Checking actual engine temps. is the test to confirm the problem.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #3
I used the procedure that uses the odometer to read coolant temp. while the engine runs. The temp. never went over 72C-162F at 70 mph in 55F weather. At 55mph the temp. is 70C-158F. Is the thermostat stuck open? This is a Calif. PZEV Duratec 2.0. Which, w/ or w/out the wire, thermostat does this engine have?
 

·
Premium Member
Joined
·
44,595 Posts
Sounds like a stuck open thermostat, sorry I can't confirm which listed alternative assy. is on yours.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #5
Tried using the VIN CODE on the NAPA and Ford parts web sites, and the Ford dealer to pinpoint the thermostat with or without the sensor. No joy. But now I know what they both look like and will try again with the mirror and flashlight. Thanks for all your help
 

·
Premium Member
Joined
·
44,595 Posts
If it helps,you're not the first that had to look at the part to tell which was used.
 
1 - 6 of 6 Posts
Top