Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
970 Posts
Discussion Starter #1
Got my VIS OEM CF hood in today. Everything was going good until it came time to install the washer nozzles I removed from my stock hood. There is nothing to hold them in!!! One side, the nozzle just slips in and falls out. The other side, it takes some effort to get it in there, but it just pops right back out. I called VIS about it and they have never heard of the problem before and suggested aftermarket nozzles (of which I can only find bling bling LED ones around here) or 3M tape (yes, they said use tape) them in.

Any help in this matter would be GREATLY appreciated!
 

·
Registered
Joined
·
496 Posts
I had the same problem with my hood too(with a few other issues). They are some f-ing liars at VIS, when I called they said the same thing to me. They know the washers dont fit, they just dont want to fix the problem. Right now I am riding with no washer nozzles. I am going to go get some some a scrap yard whenever I get the time too. I refuse to use tape on my car.
 

·
Registered
Joined
·
527 Posts
ive been hearing a lot of bad stuff about vis. i dont think id get anything from em
sorry not sure what to tell ya. im sure someone will chime in with some helpfull advice tho. good luck
 

·
Registered
Joined
·
1,660 Posts
what size are they will ones from another vehicle fit and I agree no tape
 

·
Registered
Joined
·
970 Posts
Discussion Starter #5
Why should I have to hunt down one that fits??? They should know this stuff already and list it in the description of the product or notify the purchaser at the time of purchase.

I'm having other issues with the hood. Let's just say the hood is too flat. If I lower the bump stops, the hood settles below the fender line. If I raise the bump stops to fix that, the hood has to flex over 1" to even come near latching. Their solution was to ream the mounting holes for the latching mechanism to raise it so that it will latch. Problem is that once it latches, there is at least a 1/2" gap around the headlights. To fix this, I would lower the bump stops, but then that drops the side of the hood below the fender line. Their statement: you have to accept that with an aftermarket part...nothing is going to be 100% perfect. My reply: at this point, I'd accept 90%, but it isn't even at 75%. Then the guy says that the SVTs are different from the normal ZX3, so it requires additional modification to get it to fit. I had to call BS on him on that one. First he said the hood was a different part and I told him I could prove that they are the same part, then he said the latch assembly was a different part and I told him BS on that as well. I get to wait until tomorrow to see what the supervisor has to say about all of this (I think his name is Peter).

I'm | | <---that close to cancelling the payment on it as a dispute for a defective product and let them try and prove that it isn't defective.

I guess I should have asked around...friend got one from them for his VW GTI and the skeleton detached from the top and they told him they wouldn't do anything about it.

In the end, I cannot at this point in time recommend to ANYONE to buy ANYTHING from VIS. Their solutions to problems with the poorly made product rest solely on the purchaser and purchaser takes all responsability for their poorly made product. About the only thing it is good for is leaning against the wall as a piece of art.
 

·
Registered
Joined
·
267 Posts
I have VIS, and i jus rehooked up the nozzle lines from the stock hood with the stock nozzles on the VIS, and it says perfectly fine.
 

·
Registered
Joined
·
970 Posts
Discussion Starter #7
I must have gotten a defective part then.
 

·
FF Bouncer
Joined
·
3,178 Posts
I installed a set of LED nozzles on my carbon fiber hood because I thought it would be much easier to drill out two circular holes instead of two rectangular holes. (I don't have the LEDs hooked up, I only bought them because they are chrome and I think they accent the hood better). The install was very easy and I've had no problems with them so far. My hood is an APC hood though and I've heard more bad things about VIS than good.



Cheers!
 

·
Registered
Joined
·
1,014 Posts
I did the same thing as you with the chrome ones. They arent hooked up at all either.....i havent even tried to fit stock ones on yet. I still need to go purchase the tubing for the washers/spray! I think my old one got cut off and thrown away.
-Ashley
 
1 - 9 of 9 Posts
Top