Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I've got a 2013 Focus SE. I tried starting it this morning and it wouldn't turn over. I used a portable battery charger on it, and after a lot of trying, it eventually started up.

After pulling out of my driveway, I realized none of the dash was working. No HUD, the odometer/gas/temp indicators don't move. The radio HUD will turn on, but only if I manually push the power button. Also, blinkers and headlights don't turn on.

Does anyone have any idea what could be going on here? Anything obvious I can check for before I call up the dealership?
 

·
Registered
Joined
·
202 Posts
Did you buy the car brand new? First thing that popped in my head was that it was a flood car sold at a dealer used.

Sounds like you might need to test battery and go from there. Maybe if the battery is dead enough, it wouldn't have enough juice to power dash... even with power coming from alternator. Just a thought!
 

·
Rubber Side Down
Joined
·
2,415 Posts
Is the battery staying charged? If not check the alternator belt. If that's fine your alternator may be done.
 

·
Registered
Joined
·
329 Posts
Check for blown fuses in the BCM (under the dash on pass. side behind the glovebox) Also check for blown fuses out in the fuse block near the battery under the hood. You'll wanna check mega fuse 4 (feeds BCM if power locks work, then this fuse is probably good) In the BCM check fuses 67 and 69
 

·
Registered
Joined
·
314 Posts
I've got a 2013 Focus SE. I tried starting it this morning and it wouldn't turn over. I used a portable battery charger on it, and after a lot of trying, it eventually started up.

After pulling out of my driveway, I realized none of the dash was working. No HUD, the odometer/gas/temp indicators don't move. The radio HUD will turn on, but only if I manually push the power button. Also, blinkers and headlights don't turn on.

Does anyone have any idea what could be going on here? Anything obvious I can check for before I call up the dealership?
Check fuses 26 and 29 in the passenger compartment fuse panel.
Your instrument panel cluster (gauges, driver's screen / HUD) ...(IPC) aren't working - the radio will not automatically turn on if it doesn't have communication with the IPC module.

I believe your turn signals and headlight switch are also fed into this module.

One hypothesis is that you have a short somewhere in the IPC wiring which caused the battery drain and/or blew a fuse, or there is an issue internally with the IPC which caused it to malfunction and drain your battery, also causing it not to function once you got the vehicle running.

Any obvious things you can think of, like a really humid or wet day / night before this happened?
 

·
Registered
Joined
·
3 Posts
Hi there, Im having the similar issue. I have 2013 Ford Focus St and this morning when I start my car my dashboard is dead. Non is working. My battery is fine and all the lights and signal light is working outside but the dashboard non is working. Can’t drive it because I can’t see the odometer but it was running. Anyone have an Idea what would be the problem? When I push the radio it show on the screen Shutting off batter saving something like that then it disappeared. Any input will be great? Thanks
 
1 - 8 of 8 Posts
Top