Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
I have a 2002 zx3 5sp. This mornin i started her up, instantky jump to 3500rpm n stayed there for approx. 30secs before settling at 1050rpm n then to 950rpm. On my way to work everytime i change gears, the car would stay at the high revs then come back down...coasting to a stop light produces the same results. 1 block from my office, i ran first to 4000rpm n the car stayed at that rev for 35 secs before settling down again...wat da hell is going on?
 

·
Registered
Joined
·
170 Posts
Sounds like a bad Idle air control valve.Or a sticky throttle plate.Or a bad throttle cable.
 

·
Registered
Joined
·
696 Posts
How many miles do you have on it?
 

·
Registered
Joined
·
1,512 Posts
Spray some carb cleaner around the TB and see if the idle goes down.
 

·
Registered
Joined
·
1,512 Posts
Check the vacuum lines on the back of the intake manifold. It's not uncommon for them to go bad.
 

·
Registered
Joined
·
789 Posts
^have you driven with your window down and listened to your engine while accelerating? does it make a funny 'hissing' sound at certain rpms? mine is kind of doing the same thing but it makes that hissing sound every now and then at certain rpms. i might have the same problem but i can't figure it out.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #10
cant hear my engine because of the exhaust, did find a loose vacuum line n plugged it back in but the problem seems to persist...high idle n long delay before the revs come down...ran a scan n 2 things came up...O2 sensor which i'm aware of but now there's a code BANK1...??? do not know wat it means...I live in the tropics(Jamaica) and i had replaced the thermostat n housing but the car was still running hot so i removed the thermostat...it runs fine temp is at dead center when car is warm. The only other thing i can add is that the speedometer works sparidicoly...must times it's not working at all but when it does the car drives the same for a little bit but then i notice a surge like too much fuel or something car driveability is not immediatly responsive. Touch the accelerator n the revs stay then slowly come back down to idle. CNormal Driving n changing gears the revs stay up going into the next gear.
I have an American Focus zx3 zetec year 2002
 

·
Registered
Joined
·
789 Posts
try tightening all of the exhaust bolts, everything from the exhaust manifold to the back, and see if that works. it worked for me the first time i had this problem but now i have this other problem
 
1 - 11 of 11 Posts
Top