Focus Fanatics Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi, have a 2003 Ford Focus 2.0L SOHC. When trying to take off it has no power, barely moves. Have changed fuel pump, fuel filter, new 02 sensors (as it keeps throwing codes p0135 and P0141), new catalytic converter, new throttle position sensor, new input shaft sensor on the transmission. Any help would be greatly appreciated! Thanks.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I don't see a crack in the coil pack. It doesn't really sputter, more hesitates. You can mash the pedal to the ground and it'll basically crawl. Sometimes it will eventually take off and go as long as you keep it going but if you have to stop it's the same thing again.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Thanks for your help. As an update, I found that the fuse for the o2 sensors was blown. So changed the fuse and put the coil pack back on and it ran better for a bit though still had a slight hesitation when I pushed the gas pedal. Backed it down an incline and almost immediately started having major hesitation again.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #19 ·
Just as an update, took it to a shop, they found that the harmonic balancer had gotten loose and apparently twisted some damaging the keyway and the slot for the keyway on the harmonic balancer They said that'd allow it to get a little off time, and make it hesitate like it was. Anyways, put a new harmonic balancer, keyway, etc. on there and seems to have done the trick.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top