Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hey guys, I have an 03 comp orange svt with 130K miles and this is about the 3rd time it has died in the past year. I was driving on the highway and all the lights and gauges in the car started cutting out and then finally my headlights followed by the car completely shutting off. I had to jump the car 3 times to make it home. I have replaced the alternator within the past 4 months, so I am assuming that is not the problem. I also know that I need to replace the serpentine belt... is it possible that the fix could be that easy? I am wondering what else I should be checking, any help would be greatly appreciated!
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Yea I will be checking it... I still have the receipt and the warranty is still good so hopefully Advance Auto will replace it if it is fried.
 

·
Registered
Joined
·
110 Posts
It sounds like same problem I had. I bought a 03' SVT and the pigtail from alternator was shot causing the voltage regulator in the alternator to go bad. I would suggest replacing the alternator and alternator pigtail.
 

·
Registered
Joined
·
110 Posts
Check the voltage on of your battery with a reader while your car is running, I bet yours will be extremely high. Mine was 17 or 18 before I replaced both alt. and alt. pigtail. Any battery light?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
Thanks for the reply guys. Yes for the battery light being on... it will come on and stay on and then the car dies about 2 minutes later, which leads me to believe that there is a problem charging the battery. The alternator appeared to be fine and the pigtail as well. I replaced the pigtail last year and had to splice some wires so I may check it more closely tomorrow when my brother can help me. I will most likely be replacing the alternator, pigtail and serpentine belt tomorrow. There has got to be something wrong with the electrical system in my car.... this is now the 4th alternator that will have to be replaced within less than 2 years. I may just look at going to a diagnostic place to have it checked out because I am getting really tired of this. I love these cars but I swear mine is cursed...
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
Any idea if a bad ECU can cause the alternator to get fried? I am really suspicious of this because there is no way I should have blown through 4 alternators in less than 4 years.
 

·
FF Affiliate
Joined
·
31,150 Posts
No it wouldnt be the ECU ,The SVT eats Alt like candy very common problem

The ECU controles the voltage the Alt puts out if it is high I would check the pigtail before changing the alt

Tom
 

·
Registered
Joined
·
110 Posts
Good luck! If you think you've got problems check out my current thread regarding my issues with not having turn signals, brake lights (top center) works, flashers, hvac controls, speedometer.... You'll probably feel a little better after reading that.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #10 ·
thanks guys... I will be replacing the battery terminals today since they were pretty corroded. I will also be inspecting the pigtail and the alternator. I hope I do not need to replace the alternator, but it is still on warranty from Advance Auto so hopefully I can get that for free if I need a new one.

greygoose- you were right, that did make me feel better haha

Tom one more question for you... I have an aftermarket tune on the car (not sure which one since my brother put it on before I got the car). Could this have any effect on my problems?
 
1 - 10 of 10 Posts
Top