Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
So exactly last year i put on a Cold air intake, (a cheaper one from ebay until i can afford AEM) this year im having all sorts of crazy problems. Problem one last summer when it got too hot i could not run the AC or my car would shut off. I have to pull off let it cool for a good while before attempting to drive again, i found out the breaker for the fans blew so i replaced it, it blew again so i hot wired the fans to come on when the car does. Havent had that issue since? however the thermostat never went up over half.

second, as of last month my check engine light has been on giving me an insufficiant EGR code. I replaced the EGR as i heard that has been a problem, didnt fix much and the light came back on. This time the error is 2 codes at once reading Insufficiant EGR & Excessive EGR. What the hell is that? But the car would still run. Right after having the light checked out. My car sputters like mad when i try to drive it above 40. Its almost like it completely misses 3rd gear, (its automatic) it goes to first fine, second fine, then does this high rev sound then lugs enought to throw you forward a little bit. CANT be healthy.

Has anyone else had these problems or know how to help me out before shelling out more money i dont have

thanks guys
 

·
Retired Fanatic
Joined
·
20,000 Posts
Did you do an ECU reset when you installed your intake? As well as removed it, etc? You have to disconnect the negative battery terminal when you change something 'performance related' on the car, especially anything linked to a sensor. Leave it disconnected for 10-20 minutes and then reconnect and start the car. It resets the computer so the car can 'learn' about your new mods, or return the settings to stock if you removed it.

If you didn't, that would explain alot of your problems......
 

·
Registered
Joined
·
620 Posts
Have your DPFE sensor checked. I talked to one of my service advisors here who used to be a tech and that was his suggestion.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
i just bought a new DPFE sensor last summer? Would it have gone that bad???

I did put the original air intake on and took it for a spin tonight and what a world of difference there is still slight hesitation though. and slight sputter at higher speeds
 
1 - 4 of 4 Posts
Top