Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a '03 SVT that is having some fairly regular hesitation issues at 2-2.5k rpm. It feels like a hesitation/surging typically at steady cruising at any number of speeds. This may or may not be related to an unsolved problem from the warm months of the year.
During the warm months of the year the car will go into stalling (later determined to be limp mode) on very hot days. The dealer belived it was dying due to the fuel pump and replaced it (they said SVT's don't have a limp mode?). The problem continued. It turned out to be going into limp mode because it was overheating, but not always showing on the gauges right away. I then changed the fan resistor pack which was pooched, the 2 fan relays in the engine compartment fuse box, fuel filter and the coolant temp sensor. Problem still goes on. I took the car to another new garage where I know the mechanic from when I washed cars at a Ford Dealership 15 years ago. He said the car is running lean and that is why it is overheating even when driving at highway speeds. He could not find the cause but found when he used his Snap-On magic box to turn on the fans the dsi acuator would make noise. Since my last visit to him, the winter came and the stalling ended but I still have this hesitation/surging problem?

Could it be the DSI acuator causing this problem? Maybe a bad TPS? Is there a port for checking the fuel pressure on the rail somewhere? Maybe a reflash? Causes of running lean? I love my SVT but these mystery problems strain the relationship and my wife wants me to trade it in on a Honda Civic! I need some direction, please! I am sure it will be a problem once the hot weather returns to the Great White North.

The car has a Steeda SRI, an ORP and 25k miles (40k kms). The problem started before the ORP was on and 2 years after the SRI was installed.

Much appreciation to all who take the time to read, comment or suggest.
 

·
Registered
Joined
·
329 Posts
Sounds like same problem i had when the 2 times my TPS went out. Its like 30 bucks and takes 5-10 minutes to change out. There is a spring in there an mine would not spring back properly both times i had this same issue. Good Luck and dont trade it for a civic there are millions of them and few SVT's around.
 
1 - 2 of 2 Posts
Top