Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hey fellas Im having problems with my 05 focus sputtering around lately, id be driving and id lose all throttle response for a few seconds then it would come back. took it to a shop and they say i need an aftermarket airflow sensor. I recently replaced the pcv valve and hose, afterwards a few days later i took it to auto zone and had them read the codes and it was pulling up codes for a bank on my intake manifold stuck open and another code for the pcv, cant remember the exact one. if it is the sensor does anyone know anywhere i can get one, and what are some other routes i can go to correct my problem.
 

·
Banned
Joined
·
20 Posts
i had the same problem. my cause came out to be my maf housing. i did a DIY CAI. turns out the maf housing has to be the exact same size as stock. or a retune will be needed. i dont know what CAI you have but without the factory MAF housing or a duplicate. i kept getting those same code and symptoms
 

·
Banned
Joined
·
20 Posts
also to get codes just hold down the trip reset while starting the car. then hit it to cycle thru all the tests then will say DTC and show you the code number
 

·
Banned
Joined
·
20 Posts
a pic of yours will help. the tried and true version of the DIY intake is what they call the stealth intake. a quick search should pull it up for you
 

·
Gal. 2:20
Joined
·
1,999 Posts
it could be too that your car is running to lean now asw well. sounds like multipule problems snow balling in to one big one.
 

·
Registered
Joined
·
1,484 Posts
i did the stealth intake and i don't have any problems...

...the problem is when you change out the tube where the sensor is at. Even if it is just a 1/8" smaller or larger, it will through off the readings becuase your ECU is tuned for a specific diameter tubing.
 
1 - 9 of 9 Posts
Top