Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter · #1 · (Edited)
So I found these two items today while at a part yard.

In this image you can see the rubber coupling that goes into the throttle body. This tube was slide into it and went into the top of the MAF sensor tube.


This tube came out the bottom of the MAF sensor tube and has the air filter on it. It was located near the bottom of the car, the guy didn't have the splash guard so I assume he was sucking all sorts of stuff up into his engine. (Side note: I pulled the throttle body of this car, it was bad bad bad dirty. Cleaned it and installed it on my car as I had small modifications to mine. )


Are they worth getting? I didn't see a makers mark on them. They guy had the right idea but did it ALL wrong. He had bailing wire wrapped around parts of these holding them into the piece of tube that had the MAF sensor in it. I assume this is a CAI setup but it doesn't look full.
 

·
8 DAY HOMECOMING
Joined
·
13,121 Posts
Well sure they aren't expensive to buy at a yard light that. If you will use it.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #3 ·
Problem I am having is that idk if it would work with my car. Everything looks the same but this came out of a ZX4.
Do you know if all the pieces are here?
He had it hooked up TERRIBLY as I said he was using hay bailing wire.
The TB had the coupling on it so I know that is there.
I see both tubes have mounting brackets, where does those get attached the the frame?
 

·
8 DAY HOMECOMING
Joined
·
13,121 Posts
My SRI isn't attached anywhere. It does fine on the bumps. Could be an SRI not cai? Should mount to your car. No marking at all?
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #5 ·
No markings. These are two tubes.
One leaving the TB going into the MAF sensor tube and another out the bottom of the MAF tube with tge filter on the bottom.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #6 ·
Looks like I am going to have to get this anyways. Upon further inspections I have noticed that my air filter and most of its components are cracked up....








Took off the bumper for a better view over everything, going to leave it off for now.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #7 ·


So I got those tubes today. This is how the guy had it together. I don't know if this is correct so I will be looking around on the forums.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
135 Posts
That's the setup I had on my 05 zx3. There is supposed to be a rubber bushing at bottom fork that mounts to a factory hole on inside of frame rail. Other than that I think that was only hard mount. I'd clean out inside of pipe before you try mounting it.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #10 ·
Ive not used it yet, waiting to get the pieces worked out and need a filter as the one that was on it was just metal mesh.
 

·
br/o/stang
Joined
·
5,563 Posts
yeah thats the ebay special. the tabs for the bolts on top of the MAF tube bend easy and are nowhere near right. The bottom elbow was the same when we tried to install on my buddys car- nowhere near close. Had to ziptie it to the frame rail lol.

POS, but i hope you got it for cheap and can make it work. happy to see youre not using the screen door filter
 
1 - 11 of 11 Posts
Top