Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
Has anyone ever had this problem?? I switched my headlights to some Cuzo 5000k and they are tight, but i recently painted my headlamps and noticed that the connectors were burnt to crap.. Im guessing that the headlamps burn to hot for that connector to handle..
 

·
Registered
Joined
·
289 Posts
im guessing that the headlamps burn to hot for that connector to handle
 

·
暗炎
Joined
·
1,925 Posts
Had a set of Street Glow bulbs in my stock headlights. Did the same thing. IIRC, they were an 80 watt bulb where the stocks were 55. You should be able to pick up a replacement connector at Wal-Mart or an auto parts store.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #4
I did that already, and im sure that one is gnna burn out too.. Just didnt know if my car was jacked, or if it happend to others... Going to order a HID kit off ebay, and its plug and play with the stock connectors and i didnt want the same thing happening.. But im sure it wont be as bad...
 

·
Sückn' n Blown
Joined
·
7,747 Posts
Like said above, you probably ran bulbs that were overrated for the wiring. Stick to a 55W bulb and you'll be fine.

HID kit off of eBay sounds scary.
 

·
Registered
Joined
·
289 Posts
where to get good HIDs? read that thread in the lighting and exterior forum
 

·
Registered
Joined
·
113 Posts
Discussion Starter #7
This company i trust, my friend has them on his 240sx and they look good.. If he didnt have them, i wouldnt go with ebay..
 

·
Registered
Joined
·
289 Posts
BRANDO did you read that thread?
 
1 - 8 of 8 Posts
Top