Focus Fanatics Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,297 Posts
Discussion Starter · #1 ·
everytime i pull into the driveway after driving, i smell something burning.

yesterday i popped the hood and realized it was coming from the firewall area. it smells the strongest betweent the power steering resevour and the TB.

im guessing i am having some sort of wiring prob.

anybody have this sort of problem?
 

·
C2H5OH
Joined
·
13,420 Posts
My best guess would be the alternator area, being it is between where your smell is coming from.
IIRC on the earlier Foci there was some recall for a "pinch bolt". No clue what that is being I never had mine done but I believe it had something to do with the power wire from the alt to the battery or along that line somewhere.
So I would guess that your positive wire is arcing or getting hot from poor connection or loose connection and arcing.
Being you've had an issue with a clunk I'd say the starter may be loose or arcing and engaging under TQ (loose wire flopping around?)
Check the positive wire though.
 

·
Registered
Joined
·
1,297 Posts
Discussion Starter · #3 ·
yeah that makes sense, i changed my battery terminals last nite and the plastic on the positive wire was melted right next to the terminal.

also, the main ground wire (the thick one thats only 6inches long or so and grounds right next to the battery) was really corroded. the corrosion is all the way through the wire, i stripped it back a couple times and it still had all that green stuff all over the copper. maybe that has something to do with it?

thanks
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top