Focus Fanatics Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
Well after a year of planning and an entire summer or work, headaches, bloody knuckles, scars, headaches, burnt feet (welded in shorts without socks on), setbacks, and more headaches, I finally got the ZX3 boosted and tuned. I tried to keep this as inexpensive as possible. I know with more time and know-how/practice with welding, etc I could have done this even cheaper than I did. I did manage to keep this under 2K though, and I'm happy about that. Alright, on to the components:

TD05-H 14b turbo
I'm using my stock manifold with an adaptor angled at about 20 degrees
DSM side mount IC (Thanks a bunch Rexified from WVStreets.com!)
1.75" hot side piping (came free with my BOV, thanks TunerToys)
2.5" cold side
05+ Mustang slot style MAF
42 lb/hr green top injectors
Tuner Toys/Stealthmode Performance oil lines
DSM BOV
2.5" exhaust with a trubendz flex and a 4" round Magnaflow straight through muffler
Dyno tune and X3 flash by Lasota Racing (I highly recommend them, they rule hard)
The only other mods I have are a 65mm tb, B&M short shifter, SVT suspension, and Brembo OEM brakes with Hawk HPS pads

The turbo spools slow and only hit just under 10 psi right before they let off at around 6750 rpms. I made my peak power and torque at 8-9 psi in the 4500-5500 rpm range. Not exactly what I was expecting, but it's fine with me. I ended up making 182.93 whp and 188.57 ft.lbs on a 100,000 mi stock motor. Overall, I'm real pleased with how it's turned out and even more so at the awesome job Don and Rob did tuning the car.
Enough of my rambling, here's some pics:










 

·
Registered
Joined
·
1,296 Posts
considering the money you spent id say not bad..... but with the time it took you and all the headaches you probably could have just bought a JRSC and gotten slightly less power but gotten it done in a month lol....
that said i think you did a good job.... hope you can do something about that spool time...
 

·
Shot me 3 deer!!!
Joined
·
9,247 Posts
Thats about perfect for a DD!!
 

·
AKA Toyotech
Joined
·
4,041 Posts
congrats and looks good! do i see some blood on the headerwrap lol?
 

·
FF Affiliate
Joined
·
30,966 Posts
To me , it looks like you have a LOT of work to do with that tuning , and thats with smoothing on 5

10psi you should be in the 200 range , who did the tuning ?

Tom
 

·
Something goes here
Joined
·
8,286 Posts
Dyno tune and X3 flash by Lasota Racing (I highly recommend them, they rule hard)
Here you go Tom, Looks like he is getting alot of KR through the power band. To much timing or bad gas? Also I wounder what his IAT's are looking like? That side mount cant be keeping it that cool considering the lack of airflow.
 

·
Token Engin-nerd
Joined
·
3,414 Posts
if its a 14b then it is a td04

at first i was looking at the tube going across the motor and i was like wheres the maf??? but then i realized youre probly draw-through... as always im gonna recommend you change and go to blow-through. The draw-through setup might be whats causing the wavy dyno curve, IAT sensor wants one thing but the knock sensor wants another thing.

re-do your piping and lose all those bends it will get your spool time down
 

·
FF Affiliate
Joined
·
30,966 Posts
You can run 9/10 psi with out a cooler so even tho the one he has isnt very large its better then nothing in that case

Yea I see that now missed that tuning part before , Something just isnt right with that dyno/tune

Tom
 

·
Registered
Joined
·
307 Posts
Discussion Starter #9
considering the money you spent id say not bad..... but with the time it took you and all the headaches you probably could have just bought a JRSC and gotten slightly less power but gotten it done in a month lol....
that said i think you did a good job.... hope you can do something about that spool time...
Oh I am definitely not the type of person to buy a premade, prethought out kit and slap it on and feel accomplished. If I had the option of doing this again, spending the same amount of money and I had the option to buy a premade kit, I'd still do it myself.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #10

·
Registered
Joined
·
307 Posts
Discussion Starter #11
To me , it looks like you have a LOT of work to do with that tuning , and thats with smoothing on 5

10psi you should be in the 200 range , who did the tuning ?

Tom
[email protected] Lasota Racing did the tune. What exactly do you see wrong with it? I figure part of the reason I'm not hitting what you think I should be is the turbo not spooling fast enough. I'm not sure if that's how I have the wg setup or if it's just a really old turbo on its way out.

Don said that he had it at 11 or 11.7 A/F across the board. Plus, it only took him an hour and I basically just stood there and watched. Maybe I should have seen if he could do anymore than what he did, but I was happy that I wasn't going to have to pay for 2 hours time.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #12
Here you go Tom, Looks like he is getting alot of KR through the power band. To much timing or bad gas? Also I wounder what his IAT's are looking like? That side mount cant be keeping it that cool considering the lack of airflow.
I was on 92 octane gas when I really wanted to be on 93. I don't know if it would make that much of a difference or not. Don did mention that my coolant temps were really high, so that might also have been a problem.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #13 (Edited)
at first i was looking at the tube going across the motor and i was like wheres the maf??? but then i realized youre probly draw-through... as always im gonna recommend you change and go to blow-through. The draw-through setup might be whats causing the wavy dyno curve, IAT sensor wants one thing but the knock sensor wants another thing.

re-do your piping and lose all those bends it will get your spool time down
It's kind of hard to see, but I'm running an 05+ Mustang slot style MAF and it's mounted directly in the middle of the piping that's going over the valve cover. So, I am running a blow through setup.
 

·
Registered
Joined
·
441 Posts
i think your WG is messed up or not adjusted correctly. You are hitting full boost around 4250-4500 and then have boost creep past that. Your only really hitting 10psi because of the boost creep.

Also if your coolant temps are high like he said then it might be pulling timing due to this. There is a table in the tune where at certain temps it's going to start pulling timing makeing it really hard to make any more power. If he didn't adjust this table in the tune then that is probably a problem. Unless the car is running really really hot then you need to figure out whats going on with that. Did you keep the stock fans on the radiator or not. If not you need to try to find a way to get them back in there.
 

·
Registered
Joined
·
1,036 Posts
i think your WG is messed up or not adjusted correctly. You are hitting full boost around 4250-4500 and then have boost creep past that. Your only really hitting 10psi because of the boost creep.

Also if your coolant temps are high like he said then it might be pulling timing due to this. There is a table in the tune where at certain temps it's going to start pulling timing makeing it really hard to make any more power. If he didn't adjust this table in the tune then that is probably a problem. Unless the car is running really really hot then you need to figure out whats going on with that. Did you keep the stock fans on the radiator or not. If not you need to try to find a way to get them back in there.

Yeah I think your wastegate is not working right too. If it's opening to soon you'll get bad lag a full spool at higher rpm's. The turbo you're using isn't big so it shouldn't be fully spooling that late.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #16
Well it works enough for me to be able to enjoy it right now, but I am contemplating getting a new 14b and swapping out.
 

·
FF Affiliate
Joined
·
30,966 Posts
[email protected] Lasota Racing did the tune. What exactly do you see wrong with it? I figure part of the reason I'm not hitting what you think I should be is the turbo not spooling fast enough. I'm not sure if that's how I have the wg setup or if it's just a really old turbo on its way out.

Don said that he had it at 11 or 11.7 A/F across the board. Plus, it only took him an hour and I basically just stood there and watched. Maybe I should have seen if he could do anymore than what he did, but I was happy that I wasn't going to have to pay for 2 hours time.
An HR , Well thers your problem ! It takes me all day to properly do a tune the way it should be done , thats about 1Hr doing driveability on the dyno 3 to 4 Hrs on the dyno doing WOT then another Hr or so driving around with the customer

There is no way to get a good safe tune on the Focus FI with in an Hrs time , It isnt that you didnt hit what I think you should be at , Look at others dynos and then look at yours , yours isnt smooth and that in most cases shows something not likeit should be

Tom
 

·
Token Engin-nerd
Joined
·
3,414 Posts
Well it works enough for me to be able to enjoy it right now, but I am contemplating getting a new 14b and swapping out.
ya 14b's are cheap and easy to come by but still a good turbo for low boost, thats why im gonna use one eventually.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #19
ya 14b's are cheap and easy to come by but still a good turbo for low boost, thats why im gonna use one eventually.
Oh and not to be nit-picky or anything, it actually it TD05H. You can see it on the comp. housing......unless what I'm using isn't a 14b, but I'm almost positive it is.
 

·
Registered
Joined
·
307 Posts
Discussion Starter #20
An HR , Well thers your problem ! It takes me all day to properly do a tune the way it should be done , thats about 1Hr doing driveability on the dyno 3 to 4 Hrs on the dyno doing WOT then another Hr or so driving around with the customer

There is no way to get a good safe tune on the Focus FI with in an Hrs time , It isnt that you didnt hit what I think you should be at , Look at others dynos and then look at yours , yours isnt smooth and that in most cases shows something not likeit should be

Tom
Do you charge by the hour? Do you still do tunes and what do you charge? I'll talk to Don and when/if I change my turbo out for a better one or when I get this spooling problem cleared up I'll definitely keep you in mind for my retune.
 
1 - 20 of 21 Posts
Top