Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
Wassup fellas, and (ladies). I recently purchased a set of KYB AGX's back in Feb. '06. Had them PROFESSIONALY installed. A couple of weeks after install heard a slight clunking noise during some bumps. Didnt think much of it because it wasnt constant. Today on my way from Atlanta on the interstate, everytime I hit a bump, i heard a very loud clunk from the rear trunk area like a midget was throwng around the jack. Got to the point that I couldnt take it no more because it was loud that i thought the car was falling apart. Pulled over the emergeny lane, popped the trunk, moved the speakers and pulled back the carpet. And what do i find???!!! The top of the shock that is secured in the trunk area, the bolt had completely sheared off. I do mean completely, the bolt come off, and so those like half an inch of shock cylinder. I looked in the wheel well and the shock is this flopping around and not connected to the car but by the bottom spindle. I called my installer and he told me that car was safe to drive. But i really dont think it is. Also there is no way I could have done this, what do u guys, think. Installer error, did he overtorque the nut and it broke under stress? Any suggesions would be nice. I cant take it in until Monday, so i have time to simmer for a minute to decide if they should replace it or not
 

·
Registered
Joined
·
1,247 Posts
They deff. over tightened the bolt on the top.. Go back and cry foul and have them replace that one. I have had mine on for awhile (over a year) and have had no problems at all. But I also did my own install...
 

·
Registered
Joined
·
25,627 Posts
Installer error, did he overtorque the nut and it broke under stress? Any suggesions would be nice.

^^^ That would be my guess ^^ Ask him if he put them back on with an air gun. You may be able to warranty it if its new, its so hard to say what caused it without seeing it, for sure.
 

·
Registered
Joined
·
301 Posts
but would that be safe?i dont know if it would cuz of the diffrent weld.but dont know,let me know what happens.
 

·
Registered
Joined
·
140 Posts
Discussion Starter #6
my thought was installer error, but they are not taking the wrap. I have to order another one
 

·
Registered
Joined
·
4,805 Posts
that sucks, but at least they aint as expensive as Koni.

at least you can install the rears yourself.
I have used the impact wrench a couple times on my AGX before i realized It was overkill...
 

·
Registered
Joined
·
140 Posts
Discussion Starter #8
UPDATE
I went back to my installer today after i took pics yesterday and sent them to the guy i ordered them from. Oh and for the record i ordered off ebay from a store called peformance parts. Anyway, I sent the pics and the guy at the performance parts store gave me a huge explanation about how it wouldnt be warrantied due to "bad mount" but the damn thing didnt break at the mount at broke at the top of the shaft where at bolts to the trunk. My installer said he didnt use any type of air wrench for that part of the install and the guy i bought it from is an [:)][:)][:)][:)][:)][:)][:)]. I will try to post pics How do i post pics
 
1 - 8 of 8 Posts
Top