Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter #1
So this little dealy goes back awhile http://www.focusfanatics.com/forum/showthread.php?t=260594

and now it must continue, I have had it confirmed by two mechanics that yes indeed my brake system has been contaminated with an oily substance of sort so I have a few questions.

Besides replacing my master cylinder, brake lines, and calipers what else should I replace?

Should I replace at all or just do a mega flush like 10 times over?

I figured instead of buying new maybe I could go do some U-pull it action here, what other models if any of focus use the braking components that are outfitted on the SVT?

My main problem being that ONLY my front left caliper won't apply pressure even though I've had it taken apart 3 times and it seems to be in perfect operating condition but I'm no mechanic so maybe I'm wrong, the Idea of my ABS unit going wonkey has come up, wondering if maybe I can just pull that clean it and hopefully that will take care of it?

But indeed my system is contaminated so stuff will either have to be mega flushed and cleaned or just replaced [scratch]

I haven't done anything about this yet because in the previous thread as I stated I'm only a scraping by college student so its taken sometime to acquire the funds to begin looking into fixing my ride.

I'd like to just U-pull all the parts that need replacing but as I'm not sure if this is such a good idea thought I would ask?

Thanks for the help guys/gals! [ffrocks]
 

·
slow
Joined
·
1,734 Posts
In my experience U-pull yards don't often have SVT's, you may have some trouble finding used parts there.
 

·
w/ my magic bag
Joined
·
29,468 Posts
So this little dealy goes back awhile http://www.focusfanatics.com/forum/showthread.php?t=260594

and now it must continue, I have had it confirmed by two mechanics that yes indeed my brake system has been contaminated with an oily substance of sort so I have a few questions.

My main problem being that ONLY my front left caliper won't apply pressure even though I've had it taken apart 3 times and it seems to be in perfect operating condition but I'm no mechanic so maybe I'm wrong, the Idea of my ABS unit going wonkey has come up, wondering if maybe I can just pull that clean it and hopefully that will take care of it?

But indeed my system is contaminated so stuff will either have to be mega flushed and cleaned or just replaced [scratch]

Have you tried taking the brake line's off the LF caliper & seeing if the line is ok? I'd flush the master cylinder & the ABS juntion box & line's.
 

·
Registered
Joined
·
208 Posts
Discussion Starter #4
Have you tried taking the brake line's off the LF caliper & seeing if the line is ok? I'd flush the master cylinder & the ABS juntion box & line's.
The lines have been bled a few times and fluid runs through them as it should, I even tore apart the caliper and cleaned it, finger pressure tested it and it wasn't hanging up or having any resistance.. I just don't get why it would seem the caliper is fine yet not work and all my other brakes work just fine.


Beyond that is it normal for and ABS unit to single out and individual brake? It would seem to me that if the unit failed all of the brakes would fail also?
 
1 - 4 of 4 Posts
Top