Focus Fanatics Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
having CC issues, its the brake deactivation switch but the switch test out fine, any ideas where the hot wire from that switch goes?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #4
They are both green and yellow, same as third brake light, just want to know what that write feeds our a diagrams
 

·
DTC P0606
Joined
·
3,364 Posts
... just want to know what that write feeds our a diagrams
Sorry no clue what that means...

May be this will help. Circuit is in this sequence:
Fuse 54 - green/white wire - stop lamp switch - green/yellow - brake pedal position switch - green/yellow - speed control module on firewall (pin 9)

Ensure all your brake lights including the high center mounted lights are working. CC won't work unless your brake lights all work. Check the wiring harness for chafes/shorts/breaks in the area between the hatch hinges if your center brake light is inoperative.

Check the stickies for a cruise control diagnostic self test using the steering wheel cruise control buttons.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #6
Did the test and checked all things, test came up as brake switch but on a bench test it works fine, I assume one side is power from fuse box, it's the output side I'm unsure of. Just went though this on my e350, that one was easy to work out once I had the wiring diagram, just can't find one for the svt, standard car should be the same
 

·
Registered
Joined
·
92 Posts
Discussion Starter #7
Side note, the e350 has the self test but no light in the dash to flash, pointless but I thought interesting
 

·
DTC P0606
Joined
·
3,364 Posts
If you pm me with an outside e-mail address, I can send you the wiring diagram fwiw. It'd be for an '02. (SVT was 02 - 04 and normal ZX3/5 would be the same.)
 

·
Premium Member
Joined
·
44,595 Posts
Call me Cap'n obvious, but if the bench test of the switch was good the first check would be to see if it's being applied when it shouldn't be to turn off the CC.
 

·
DTC P0606
Joined
·
3,364 Posts
True. Not sure what the actual problem symptoms are though other than "cc issues".
Anyway, pdf sent Caulkins.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #11
I checked the motion of the switch, it's all good, I did get the diagrams for it and should be able to track it down in the morning. I bought the car from a Meth addict who did what they do to cars, got everything else fixed, this is last on the list. For a thousand dollar car I'm willing to chase a few wires. Should be easy to find with the diagrams, thanks again for the info, I will update on the solution.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #12
Have yet to put the part in but I'm thinking it's the clutch switch, should have a new one next week but in looking into it I read that the car will shift better with it unplugged. This might fall into the category of things you read online but it has a few extra wires so it does more than just cruise control and at least my svt does not shift smooth if driving easy, but fine when giving it hell, any thoughts?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #13
edit on my last post, all 3 peddle switches work fine, tested in car, not a bench test. feed from switches test fine on the cruise control module on the fire wall. The built in test seems to pass, I get a flash with every button i push and the servo kicks in at the end. yet still while driving the cc light will not come on and the servo will not engage. Any input could be helpfull.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #14
True. Not sure what the actual problem symptoms are though other than "cc issues".
Anyway, pdf sent Caulkins.
I came up with another symptom driving my other ford to work today, the E350 will kill the cruise if I use the turn signal, I assume the focus is the same. On the focus the blinker goes to fast like a bulb is out but its not, If looking close at the dash in pitch dark the signal indicators are slightly lit up. My thought is that is the dash is getting a slight signal than the CC is getting the same one but even if i am right I would think the CC dash light would come on but I would not be able to set it.

Also I am getting way off the original topic but dont know how to retitle this and move it to the right section.
 
1 - 14 of 14 Posts
Top