Focus Fanatics Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi, I've got an 03 Ford focus ZX5. My brake lights are being goofy, they only work in Park. I was curious if anyone else has encountered this issue. I was researching an issue I had earlier this week (car just decided not to start and made 0 effort) while looking that up "neutral safety switch" came up. Car runs now, nothing fixed. Was wondering if that could also be the culprit with brake lights.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,589 Posts
Weird things happen with brake lights when wires begin to short out in the harness to the rear hatch.

Pull the rubber boot back on the harness that connects body to hatch and examine wires inside.

Note: The rubber boot can be difficult to get back on, but it will go.
 

·
w/ my magic bag
Joined
·
29,468 Posts
I'd also look underneath the column at the brake switch too.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Would the fact that one of the bulbs looks like it's on its almost ready to burn out cause this issue?
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,589 Posts
Bulbs can develop black spots inside the glass. It doesn't mean anything other than it is not a new bulb.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
Right after I posted that it blew out. But I switched both. So I figured out where the brake switch is. Now there are no brake lights when pushing the pedal but if I push it with my finger on park it works but still not drive. BTW thanks for the help... I do appreciate it tons since I'm not very car smart.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Also, idk if this helps but when I push the brake switch with my finger in Park I hear a clicking by the gear shifter but not when in drive.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,589 Posts
...if I push it with my finger on park it works but still not drive.
I'm not entirely sure what you mean by that, but if pushing the brake pedal makes the brake lights come on, then switch is fine.

I think your brake switch is okay...you said in your opening post that the lights worked in Park.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,589 Posts
Also, idk if this helps but when I push the brake switch with my finger in Park I hear a clicking by the gear shifter but not when in drive.
That is the solenoid that operates the shift lock. Normal to hear that.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #11
Oops sorry. When I push the little pin with my finger it makes the brake light work in Park only. But now the brake pedal being push won't even make the brake lights come on in Park. I think I broke something more?
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,589 Posts
...now the brake pedal being push won't even make the brake lights come on in Park. I think I broke something more?
You may have blown a fuse now. All the more reason to check for wiring problems. Did you look at the harness yet?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #14
I looked but to be honest, not 100% how to see any wire issues.... A little scared to take electric tape off. I just read something while looking around the internet. I'm willing to put money on the fact it is wiring tho.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #16
Ok so this is embarrassing to admit but I was looking in the wrong spot before the video. I'm looking in the right spot n it looks like someone has taped these wires before. I'll post a pic in a few mins.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #19
Yeah, looks like it. Thank you so much for being patient with me :) I tore apart the wrong part of my hatch before the video. :-/
 
1 - 20 of 30 Posts
Top