Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
I noticed my head lights were out. I checked the fuses under the hood and they were all ok. I then replaced both bulbs and they still don't work. What am i doing wrong here? What am I missing?

Thanks for the help!!
 

·
ELVIS LIVES !
Joined
·
2,553 Posts
Check the connectors and make sure they are lined up and making good contact. That is what the bulbs hook up to. Also check the metal pins coming out of the bulbs to make sure they also line up.
 

·
ELVIS LIVES !
Joined
·
2,553 Posts
It may also be in the light switch itself if the above does not work.
 

·
Premium Member
Joined
·
44,595 Posts
Both high & low out?

Did you identify the fuses by diagram? (not sure where yours are, there's also an interior fuse panel)

Look for a relay in the system? Swapping with an identical not currently in use is a quick check for those.

Next step after Godzukidan's checks might be checking for power/ground at the plugs with a meter.
 

·
ELVIS LIVES !
Joined
·
2,553 Posts
Yes the fuse box is behind your cd holder built in your dash. You will have to take the cd holder off to get to it.
 

·
Vince your Moderator
Joined
·
5,074 Posts
There is a relay also.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #8
Thanks for the reply's. I will take a look at the fuses in the car right now. Well after my coffee. :)
 

·
Registered
Joined
·
82 Posts
Discussion Starter #9
Got it fixed

There was a problem between the steering wheel and the front seat :-D
 

·
ELVIS LIVES !
Joined
·
2,553 Posts
[twothumbs] LOL happens to me a lot. Glad you got it fixed.
 
1 - 10 of 10 Posts
Top