Focus Fanatics Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
I dunno if any of you guys have ever tryed them before or not, but i got some bosch spark plugs to go with my new wires, well after the install my car fliped out. it acted like it wasnt firing correctly. i double checked everything with the bosch plugs and it still sputtered, so i just put the old motorcrafts back in and it was fine. but yeah word of advice, dont get these plugs. the focus hates them. and my cars in great shape.
 

·
Registered
Joined
·
5,679 Posts
get autolite doule platinum !

word is...they are the best for our car....

Joel
 

·
Registered
Joined
·
115 Posts
Discussion Starter #3
i'll look but if they arent the exact same size as the ones in it now i wont use em. the guy at the car parts store said the bosch one would fit my car, i noticed they were a smaller. turned out they made my car angry. hell even the plugs part numbers on their site for my car matched the part numbers on the plugs. but nope, still angry mean evil car![}:)]
 

·
Mr. Wizard
Joined
·
937 Posts
bosch plugs burn too hot for the Focus, at least that is what I've heard, I have the Autolite Double Platinum's and they work very nicely. (Also make sure that the plugs are gapped correctly, otherwise it will do the same thing. Not all plugs come pre-gapped, and my Autolites didn't so if you put plugs in that haven't be properly gapped you'd get the same problem that you described as well.
 

·
Registered
Joined
·
793 Posts
I used bosch Platinum +4 and it ruined my ECU, I had to get a new one from ford, ruined the timing any everything, dont try any other type of plugs....
 

·
Registered
Joined
·
74 Posts
I just put in Bosch +2s. When I have the AC on it idles butt smooth. If I idle with AC off it seems to have a slight miss to it (feels like a miss anyways), you guys think its from the Bosch +2s?? I was actually thinking about going with NGK plugs next, but if Autolite DBL Plats are working good then thats what Ill use.
 

·
Registered
Joined
·
341 Posts
all BOSCH plugs DONT WORK FOR OUT CARS!!! dont put them in, and if u dont know/how to gap plugs, then dont fool w/the stuff.

-Ult
 

·
Registered
Joined
·
74 Posts
Ill change my plugs out this weekend and see if that miss goes away. Also, UltegraSTI, I noticed you run 15.0 in the 1/4 mile.. what mods do you have to achieve this?
 

·
Registered
Joined
·
74 Posts
I just wanted to thank you all for bringing this topic up. I took out my Bosch +2s (been using them for 2 weeks) and replaced them with Autolite DBL Platinums and my idle is now smooth and it runs great now. I kinda thought my mileage was crappy too and im sure that will be better now too. BTW, the Bosch plugs were much shorter than the Autolites. Anyhow thanks again!!
 
1 - 15 of 15 Posts
Top