Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
a few days ago i was changing the little latch that opens the hood. ever since then my battery light has been on. i replaced the alternator and my battery is good, even tested it, starter is good. basically everything is good just the light is on i accedennaly rubbed one of the wires from underneath the car where the fuses are into a metal plate and it made a litle spark and my light has been on since. any one have any ideas what the problem could be and how i can fix it?
 

·
has a screw loose
Joined
·
9,927 Posts
If it were me , I would take it to a dealer and have them look at it because you don't want to trigger anything that might set the air bag off and blow up in your face while your driving.
Have you tried removing your negative battery cable for about 15 minutes and reattach? That might reset it for you , I know in my F 150 work truck I had a CEL along with the battery light indicator come on and it was the air bag sensor messed up in the steering wheel.
 

·
Hatch Nation #136
Joined
·
2,043 Posts
a few days ago i was changing the little latch that opens the hood. ever since then my battery light has been on. i replaced the alternator and my battery is good, even tested it, starter is good. basically everything is good just the light is on i accedennaly rubbed one of the wires from underneath the car where the fuses are into a metal plate and it made a litle spark and my light has been on since. any one have any ideas what the problem could be and how i can fix it?
Check that wire!

The battery light lets you know something is wrong with your electrical system and that wire is part of your electrical system. Then start looking at fuses to see if anything blew when you were sparking.

KISS principle.
 
1 - 3 of 3 Posts
Top