Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
My battery light just came on last night. I was racing and I was in 4th gear and all of a sudden it came on. It's happened before, but it went away for some reason. Last time I checked under the hood and there was a lot of corrosion around the battery so I blew it all off and the light turned off eventually. It's weird though because it doesn't stay on. It only comes on when the car is under about 2k rpms. Anyone know the problem?
 

·
Registered
Joined
·
25,627 Posts
First things first, take those terminals off and get them squeeky clean, even some dielectric grease putting them back on... Then see if you have any issues, I would check the voltage on the charging system to see if its okay as well.
 

·
Registered
Joined
·
9,084 Posts
Its a good chance you may need a new alternator.
 

·
Registered
Joined
·
87 Posts
It sounds like the diodes in the alternator are starting to go bye bye.
check the charging voltage. If it is below 13.2, replace the alternator.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
How do I check the charge on the alternator?

Sorry for being a noob.[8]
 

·
Registered
Joined
·
121 Posts
Raceing at Engilsh Town? << Old Bridge. Test and Tune? or just street? Dude clean off those scale from your terminals and try again. The Alt is not a fun job, start with the easy stuff.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
Well, today I was about to leave my development and the car shut off. So I turn around and am about to park my car and it shuts off agian. The first time was when I came to a complete stop. The second time I was slowing down and my rpms were under 1000. It almost happened agian, like I felt it want to die, but I gave it some gas so the car wouldn't die. I parked it and it shut off agian. Then I started it back up and left it running without touching anything for about 2 minutes. It didn't shut off, but the battery light is still on.
 

·
Registered
Joined
·
121 Posts
Damn, I'm watchin the Yanks game. good game. F the Sox.

I had an RPM prob too. It might be your IAC valve. Idel air controle valve. Mine went and screwed up the idel RPM's for a while. I have not changed my IAC. I cope.

As soon as your foot is off the accelerator it dies. right?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #9
Well, sort of. When the car comes to a complete stop or when the car is moving really slow the light turns on and it sometimes feels like it wants to die. Like it kind of shakes a little and the RPMS go really low. You think it could have to do anything with my tune? I'm not sure what I set my Neutral idle and my Drive idle to.
 

·
Registered
Joined
·
121 Posts
Well it could be that, or your IAC valve is just shot. tough to tell from here. Sound more like an IAC prob though.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #11
How would I go about getting that checked out or fixed. Say I get this fixed, then my battery light should turn off and I should be fine?
 
1 - 11 of 11 Posts
Top