Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
140,000 miles on an '03 spi engine. I've never had anything replaced except for oil changes, spark plugs and wires. It mostly misfires in 2nd and 3rd gear at low rpms. Should i replace the fuel filter, sensors, and injectors for high mileage maintenance anyways?
 

·
Premium Member
Joined
·
21,250 Posts
Hmmm, with that mileage I'd be interested in the condition of the timing belt, but I'm not sure if SPI's are belts or chains since I've never owned one.

You should test the coil pack, and if you have lifetime warranty wires, replace those also. The fuel filter is supposed to be changed every 25-30k miles. If you haven't replaced it, then you should definitely do so. As far as the sensors, wait, I always suggest catching up with regular maintenance, and then testing to determine what is causing the problem. I'd also pull the spark plug wires and see what kinds of deposits are built up on the plugs. I'd then use a knife to clean the plugs, and check the gap before re-installing.

As a guess, when was the last time you changed plugs? Sometimes spark plugs loosen over time. This generally causes a problem when the engine is cold, and at low rpm. If that is your problem, great, but you should definitely catch up on regular maintenance.
 

·
Aurelius Pardus
Joined
·
26,535 Posts
oh yeah...... and I'd really recommend just getting like a whole system flush..... and new filters and all that stuff...... I did on my SPI with 108k and it felt SO much better, performance and mileage wise [thumb]
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Today no misfiring at all. So apparently there's some reason why it happens some days and some not. And today was a rainy day as well so moist does not aggravate it. Thanks for the replys!
 
1 - 5 of 5 Posts
Top